Введение в Pro/ENGINEER Wildfire 2.0.

Page 1 of 76 Next

Pro/ENGINEER Wildfire 2.0 для новых пользователей

>>> Пожалуйста, нажмите Next в верхнем правом углу на этой странице для продолжения.


Previous Page 2 of 76 Next

Введение

Окно этого учебника можно расположить рядом с Pro/ENGINEER Wildfire 2.0.

  • Убедитесь в том, что Pro/ENGINEER Wildfire 2.0 установлен на этом компьютере.
  • Если Pro/ENGINEER сейчас запущен, то нужно выйти из него.

Для начала необходимо подготовить стартовую команду для Pro/ENGINEER и расположить модели Pro/ENGINEER для этого учебника:

  1. Скачать файлы моделей нужно Отсюда (или с сайта РТС). Сохраните архив на компьютере.
  2. Распакуйте архив на жесткий диск компьютера.
    • Рекомендуется распаковать на диск C:\.
  3. Просмотрите - правильно ли создалась структура папок.
    • Например: C:\users\student\HOW_INTRO-WF2
  4. Убедитесь, что Pro/ENGINEER Wildfire 2.0 установлен на компьютере и перетяните ярлык из меню "Пуск/Программы/PTC/Pro ENGINEER/Pro ENGINEER". Для этого:
    • Правой кнопкой мыши щелкните на ярлыке Pro ENGINEER и выберите Копировать.
    • Правой кнопкой мыши щелкните на рабочем столе и выберите Вставить ярлык.
  5. Правой кнопкой мыши щелкните на полученном ярлыке и выберите Свойства.
    • Введите (или скопируйте отсюда) полный путь до рабочего каталога Intro_HOW.
    • Например: C:\users\student\HOW_INTRO-WF2
  6. Запустите Pro/ENGINEER Wildfire 2.0 используя полученный ярлык.


Previous Page 3 of 76 Next

Использование этого учебника

  • В зависимости от предпочтения можно либо продолжать читать учебник на компьютере, либо распечатать его.

    • Версия для печати

    • Рекомендуется цветной принтер.

  • Нажмите Next или Previous в верхних углах каждой страницы для прохождения по учебнику.
    • Точно также можно нажать Next внизу каждой станицы.
  • Внимательно прочтите содержание каждой страницы и выполняйте указанные шаги перед тем, как перейти на другую страницу.
    • Иногда может попасться команда 'scroll down' на странице учебника перед продолжением.
  • Можно вернуться на начальную страницу, нажав кнопку Home внизу каждой страницы.
    • Из начальной (Home) страницы можно быстрее перескочить на нужный урок.
  • Можно заметить следующие иконки на всем протяжении учебника:
    • Information Information обеспечивает начало большинства задач.
    • Tip Tips обеспечивает подсказками по всему учебнику.
    • Note Notes обеспечивает дополнительной информацией.
  • Существуют некоторые условности при работе с Pro/ENGINEER Wildfire 2.0:
    • "Укажи и нажми" ("picks and clicks") показаны Жирным.
    • Текст, который нужно вводить с клавиатуры показан Жирным.
    • Иконки и их названия расположены в одной строке текста.
    • Имена моделей показаны заглавными буквами.
    • Кнопки клавиатуры показаны заглавными буквами.
  • Можно настроить нужный размер шрифта двумя методами:
    • Нажать Вид> Размер шрифта в окне Internet Explorer.
    • Нажимая CTRL и вращая колесико мышки.
  • Расположите окна учебника и Pro/ENGINEER Wildfire 2.0:
    • Растяните окно учебника приблизительно на 70 мм в ширину.
    • Сделайте окно Pro/ENGINEER Wildfire 2.0 меньше приблизительно на 70 мм в ширину после его загрузки.
    • Расположите учебник слева от окна Pro/ENGINEER Wildfire 2.0 как показано на картинке ниже. Это будет лучше восприниматься в процессе работы.
    • Рекомендуется сделать разрешение экрана побольше, например 1600x1200, для расширения рабочей области.

Позиционирование окна учебника


Previous Page 4 of 76 Next

Добро пожаловать

Этот учебник поможет приобрести базовые навыки моделирования деталей, а также созданию сборок и чертежей. Этот учебник разработан для студентов, которые никогда не пользовались Pro/ENGINEER.

Содержание

Нажмите Next для продолжения обучения основам Pro/ENGINEER Wildfire 2.0 или используйте следующие ссылки для навигации по разделам внутри этого учебника:

  • Pro/ENGINEER Wildfire 2.0 Основные понятия
    • Изучение основ Pro/ENGINEER Wildfire 2.0
  • Упражнение 1: Открытие, Ориентирование и Редактирование Моделей
    • Описание основ Pro/ENGINEER Wildfire.
    • Навигация по интерфейсу Pro/ENGINEER Wildfire.
  • У пражнение 2: Создание моделей деталей
    • Просмотр, открытие и ориентация разработанных моделей.
    • Создание моделей простых деталей.
  • У пражнение 3: Создание сборок
    • Создание сборки.
    • Запуск простого механизма.
  • У пражнение 4: Создание чертежа
    • Создание чертежа с видами сборки и детали.
    • Отображение и манипуляция с размерами на чертежных видах.
  • У пражнение 5: Ассоциативность модели
    • Модификация модели и исследование обновления сборки и чертежа.
    • Проверка пересечений в сборке.


Previous Page 5 of 76 Next
Information

Секция основных понятий

Прочитайте пять страниц этой секции основ Pro/E Wildfire 2.0 перед тем как приступить к первому уроку.

Pro/ENGINEER Wildfire 2.0 Основные понятия

В этом учебнике рассматриваются шесть основных понятий Pro/ENGINEER Wildfire 2.0:

  • Твердотельное (Solid) моделирование
  • Элементное (Feature) планирование
  • Параметризация
  • Зависимости Родитель / Потомок
  • Ассоциативность
  • Центральная модель


Previous Page 6 of 76 Next

Твердотельное (Solid) моделирование

Pro/ENGINEER Wildfire 2.0 позволяет простым образом создавать 3D модели, с возможностью показывать детали и сборки реалистичного вида. Основанные на таком свойстве материала, как плотность, эти модели имеют массу, объем, площадь поверхности и другие физические свойства, такие как центр тяжести.

Для примера, рассмотрим образец блока алюминиевого двигателя, показанный ниже. Эта модель была создана в миллиметрах, ниже приводятся ее массовые свойства. Координатная система, обозначенная цифрами 123, показывает центр тяжести модели.

У твердотельного моделирования есть следующие достоинства:

  • При изменении модели (например, увеличении числа охлаждающих ребер), все массовые свойства будут автоматически обновлены.
  • В твердотельных (Solid) моделях всегда можно настроить поля допусков и проверить зазоры/пересечения между компонентами в сборке.

ОБЪЕМ = 3.332e+04 MM^3
ПЛОЩАДЬ ПОВЕРЖНОСТИ= 2.488e+04 MM^2
ПЛОТНОСТЬ = 2.7e-06 KG/MM^3
МАССА = 8.998e-02 KG

ЦЕНТР ТЯЖЕСТИ
X = -0.642 MM
Y = 20.508 MM
Z = 24.194 MM

Твердотельная модель и ее массовые характеристики


Previous Page 7 of 76 Next

Элементное (Feature) планирование

Модели Pro/ENGINEER Wildfire 2.0 конструируются при помощи последовательности элементов-фичеров (features). Каждый элемент-фичер строится на предыдущем элементе-фичере, тем самым последовательно создается модель. Каждый из элементов-фичеров в отдельности может быть простым, но совместно они создают сложные формы деталей и сборок.

На следующем рисунке показан шатун на различных стадиях создания:

  1. Элемент-фичер Выдавливание (Extrude) формирует предельную форму и размер модели.
  2. Дополнительный элемент-фичер Выдавливание (Extrude) создается сверху и снизу модели.
  3. Элемент-фичер Отверстие (Hole) создается сверху и снизу модели.
  4. Элемент-фичер Скругление (Round) создается сверху и снизу модели.

Элементы-фичеры ШАТУНА


Previous Page 8 of 76 Next

Параметричность

Управлять моделями Pro/ENGINEER Wildfire 2.0 можно через значения размеров. Если размер элемента-фичера изменятся, то тело элемента-фичера обновляется. Это изменение автоматически передается по наследству всем остальным элементам-фичерам модели, обновляя всю деталь.

Зависимости Родитель/Потомок

Зависимости Родитель/Потомок обеспечивают мощный способ запечатлеть Вашу "цель разработчика" в модели. Зависимости Родитель/Потомок автоматически созданы между элементами-фичерами в течение процесса моделирования. Во время создания элемента-фичера, существующие элементы, на которые он ссылается - являются родителями для этого нового элемента-фичера. К тому же, при обновлении родительского элемента-фичера, элемент-фичер потомок также будет обновлен.

На следующем рисунке, модель ПОРШНЯ имеет высоту 18.5 с размером до отверстия 8 от верхней поверхности. Размер высоты был изменен до 24 и модель была Обновлена (Regenerate) для того, чтобы обновить эти элементы-фичеры. Обратите внимание, как зависимость Родитель/Потомок между отверстием и телом модели принуждает отверстие передвинуться верх для сохранения размера 8.

Редактирование высоты
ПОРШНЯ

Это поведение (отверстие, ссылающееся на верхнюю поверхность) - пример осуществления цели разработчика, которая задана в модели. В другом случае, отверстие может ссылаться на нижнюю поверхность, следуя уже по другому пути при изменении высоты модели.


Previous Page 9 of 76 Next

Ассоциативность и Центральная модель

Если модель детали Pro/ENGINEER Wildfire 2.0 была изменена, любые сборки или чертежи, которые ссылаются на эту модель, будут автоматически обновлены. Такое поведение называется Ассоциативностью (Associativity) и также работает в обратном порядке - если размер модели в чертеже обновился, то модель детали или сборки, используемая для этого чертежа, также будет обновлена.

Модель детали это центральный источник информации разработчика. Однажды созданная модель может быть:

  • Помещена в сборку - в зависимости от способа размещения компонентов, они могут быть закреплены неподвижно или могут быть приведены в движение как механизм.
  • Использована для создания чертежа - двухмерные виды модели могут быть быстро размещены на листе чертежа и размеры могут быть автоматически показаны.

Ассоциативность модели


Previous Page 10 of 76 Next

Интерфейс Pro/ENGINEEER Wildfire 2.0

Вот следующие основные компоненты интерфейса:

  • Графическое Окно (Graphics Window) - большая серая область для отображения модели.
  • Навигатор (Navigator) - выдвигаемые панели слева экрана.
    • Браузер (Browser) - многофункциональный веб-браузер, отображающий список моделей и маленькое окно предварительного просмотра по центру экрана.
    • Дерево Модели (Model Tree) - список элементов-фичеров детали или компонентов в сборке; слева от экрана.
    • Дерево Папок (Folder Browser) (не показано) - отображается слева от экрана на месте дерева модели и показывает дерево папок на компьютере или в локальной сети. Можно посмотреть папки и увидеть их содержание в Браузере.
  • Главное Меню (Main Menu) - расположено сверху экрана; это меню с выпадающими командами, которое содержит обычные опции, такие как Файл (File), Редактировать (Edit), Вставить (Insert), Инструменты (Tools) и Справка (Help).
  • Главная Панель Инструментов (Main Toolbar) - панель с иконками, расположенная сверху экрана.
  • Панель Элементов-фичеров (Feature Toolbar) - панель с иконками, расположенная в правой части экрана.
  • Инструментальная панель (Dashboard) (не показана) - диалоговая панель, располагающаяся снизу экрана во время создания элементов-фичеров.


Previous Page 11 of 76 Next
Урок 1: Открытие, ориентирование и редактирование моделей.

Обзор - в этом уроке изучаются три основных навыка, которые необходимы при моделировании в Pro/ENGINEER Wildfire 2.0

  • Предварительный просмотр (Preview) и открытие разработанных моделей - Вы будете использовать Навигатор (Navigator) и браузер (Browser) для обзора папок, предварительного просмотра и открытия моделей.
  • Ориентирование разработанных моделей - после открытия существующей модели, Вы будете использовать сочетание кнопок клавиатуры и мыши для Вращения (Spin), Смещения (Pan) и Масштабирования (Zoom) моделей.
  • Редактирование существующих разработанных моделей - после изучения основ ориентирования модели, Вы будете использовать команды редактирования для модификации существующих моделей.


Previous Page 12 of 76 Next
Information

Рабочая папка (Working Directory)

Рабочая папка (Working Directory) является папкой, из которой производится открытие и в которую производится сохранение моделей.

Задача 1-1. Открытие модели ENGINE_BLOCK.PRT, используя Навигатор (Navigator).
  1. Запустите Pro/ENGINEER Wildfire 2.0, если необходимо. По умолчанию в Браузере отображается веб-страница с содержимым из папки запуска Pro/ENGINEER Wildfire 2.0.
  2. В Навигаторе Папок (Folder Browser) [image] (слева экрана), выберите папку HOW_INTRO-WF2 и раскройте ее, нажав '+'.
  3. Выберите папку ProE_models для обзора содержимого в браузере.
  4. Нажмите правой кнопкой мыши на папке ProE_models и выберите команду Задать Рабочую Папку (Set Working Directory).
  5. Выберите ENGINE_BLOCK.PRT из браузера.
    1. Обратите внимание на предпросмотр модели, появившийся вверху браузера.
  6. Нажмите кнопку Открыть Файл в Pro/E (Open File in Pro/E) [image] из браузера (справа от окна предпросмотра).

ENGINE_BLOCK.PRT


Previous Page 13 of 76 Next
Information

Команды ориентации модели

Вращение (Spin): Вращение модели на экране.
Смещение (Pan): Смещение модели на экране.
Масштабирование (Zoom): Приближает или отдаляет модель от Вас.
Стандартная ориентация (Standard Orientation): Ориентирование, которое служит для возврата в начальное положение обзора модели.

Задача 1-2. Практика использования Вращения (Spin), Смещения (Pan) и Масштабирования (Zoom) модели ENGINE_BLOCK.

  1. Для вращения модели нажмите и удерживайте среднюю кнопку мыши и двигайте мышь в различных направлениях.
  2. Нажмите кнопку Список Сохраненных Видов (Saved View List) [image] на главной панели инструментов (сверху экрана) и выберите Стандартаную ориентацию (Standard Orientation).
  3. Приближение и отдаление модели :
    • Расположите указатель мыши на желаемую область модели.
    • Нажмите клавишу CTRL, нажмите и удерживайте среднюю кнопку мыши и, передвигая мышь на себя, приблизьте модель к себе.
    • Нажмите клавишу CTRL, нажмите и удерживайте среднюю кнопку мыши и, передвигая мышь от себя, отдалите модель от себя.

Note
Начальное положение указателя мыши определяет область масштабирования.

  4. Если мышь имеет колесико, то попробуйте с помощью него масштабировать модель:
    1. Покрутите колесико на себя для увеличения (без использования клавиши CTRL).
    2. Покрутите колесико от себя для уменьшения.
  5. Нажмите кнопку Список Сохраненных Видов (Saved View List) [image] на главной панели инструментов и выберите Стандартную ориентацию (Standard Orientation).
  6. Смещение модели на экране:
    1. Нажмите клавишу SHIFT, нажмите и удерживайте среднюю кнопку мыши и двигайте мышь в различных направлениях.
  7. Нажмите кнопку Список Сохраненных Видов (Saved View List) [image] на главной панели инструментов и выберите Стандартную ориентацию (Standard Orientation).
Tip

Можно использовать сочетание клавиш CTRL + D как комбинацию для возврата к Стандартной ориентации (Standard Orientation).


Previous Page 14 of 76 Next
Information

Выбор при помощи мыши

Двигайте мышку по элементам-фичерам для их подсветки. Нажмите левую кнопку мыши для того, чтобы сделать выбор. Голубой цвет (светло синий) подсветки показывает предварительный выбор элемента. Красный цвет подсветки показывает выбранный элемент. Поскольку элемент-фичер был выбран, то его кромки или поверхности останутся подсвеченными.

Задача 1-3. Выбор крепежного фланца.

  1. Подсветите и выберите элемент-фичер как показано на следующем рисунке:
    • Поместите указатель мыши над элементом-фичером ВЫТЯГИВАНИЕ_2 (EXTRUDE_2) так, чтобы подсветка стала голубого цвета.
    • Выберите элемент-фичер ВЫТЯГИВАНИЕ_2 (EXTRUDE_2) нажав на него левой кнопкой мыши (кликните) так, чтобы он подсветился красным цветом.

Tip
Увеличьте модель, для упрощения выбора.

Подсветка элемента-фичера (Feature)

  2. Нажмите левой кнопкой мыши (кликните) на окружающий модель фон, для снятия выбора.
  3. Подсветите и выберите ВЫТЯГИВАНИЕ_2 (EXTRUDE_2) снова.
    1. Оставьте этот элемент-фичер выбранным и продолжите упражнение.


Previous Page 15 of 76 Next
Information

Команда Править Определения (Edit Definition) и Указатели (Handles)

Команда Править Определение (Edit Definition) открывает инструментальную панель к элементу-фичеру, благодаря которой можно произвести любые необходимые корректировки этого элемента-фичера.

Работа по принципу 'нажмите правой* и подождите' используется для доступа к всплывающему меню, тогда как быстрое 'нажмите правой* и получите' будет подсвечивать следующий элемент-фичер под указателем мыши. (*Нажмите правой кнопкой мыши)

Указатели (handles) это маленькие белые квадратики, расположенные на желтой заготовке элемента-фичера.
Задача 1-4. Правка определения крепежного фланца ВЫТЯГИВАНИЕ_2 (EXTRUDE_2) для его утолщения.

  1. После выбора элемента-фичера ВЫТЯГИВАНИЕ_2 (EXTRUDE_2) нажмите правой и подождите, выбрав затем пункт Править Определение (Edit Definition).
    1. Обратите внимание, что в процессе переопределения не показывается, как создавался этот элемент-фичер.
  2. Потяните указатель (handle) глубины на модели (белый квадратик на желтой заготовке) от 2 до 5, как показано на следующем рисунке.
    1. Заметьте, что величина глубины была обновлена на инструментальной панели (внизу экрана).

Переопределение элемента-фичера

  3. Нажмите кнопку Применить (Complete Feature) [image] справа инструментальной панели (снизу экрана).
    1. Модель с множеством элементов-фичеров, располагающихся после этого вытягивания, через некоторое время будет обновлена.
    2. Заметьте, что эта модификация коснулась также противоположной стороны модели, что обусловлено наличием зависимостей Родитель/Потомок.


Previous Page 16 of 76 Next
Information

Редактирование размеров элемента-фичера

Команда Править (Edit) отображает размеры элемента-фичера и позволяет вводить новые значения. После этого необходимо Обновить (Regenerate) модель для ее обновления.

Задача 1-5. Редактирование размеров крепления карбюратора и отмена изменений.

  1. Подсветите и выберите элемент-фичер вытягивания как показано на следующем рисунке.

Выбор элемента-фичера

  2. Нажмите правой и подождите, затем выберите Правка (Edit). Появятся сечение и размеры элемента-фичера.
  3. Дважды кликните на размере 14.5, введите 11.5 и нажмите клавишу ENTER.
  4. Нажмите кнопку Обновить (Regenerate) [image] на главной панели инструментов (сверху экрана) для обновления модели.

Модель обновилась

  5. Нажмите кнопку Отменить (Undo) [image] на главной панели инструментов (сверху экрана) для отмены последней редакции.

Tip
Можно нажать CTRL + Z для вызова команды Отменить (Undo).


Previous Page 17 of 76 Next
Information

Создание скругления

Скругления (Rounds) позволяют добавлять и убирать материал модели, прилагая радиус к кромке. Можно просто выбрать кромку, назначить радиус и получить элемент-фичер.

Задача 1-6. Создание скругления на креплении карбюратора для сглаживания острой кромки.

  1. Нажмите кнопку Скругления (Round Tool) [image] на панели элементов-фичеров (справа на экране).
  2. Выберите кромку, как показано на следующем рисунке.
    1. Заметьте, что скругление автоматически следует по цепочке касательно расположенных кромок.

Выбор Кромки (Edge)

  3. Потяните за любой указатель (handle) радиуса (белый квадратик на желтой заготовке) до значения 1.
  4. Нажмите Применить (Complete Feature) [image] на инструментальной панели (снизу экрана).
    1. Заметьте, что элемент-фичер Скругление (Round) располагается в самом низу дерева модели (слева экрана)

Скругление (Round) создано


Previous Page 18 of 76 Next
Information

Отменить / Вернуть (Undo / Redo)

Можно использовать команды Отменить (Undo) и Вернуть (Redo) для исправления неудачных действий.

Задача 1-7. Удаление скругления и Отмена (Undo) удаления.

  1. Произведите выбор скругления (подсветка красным цветом), нажмите правой и подождите, выберите Удалить (Delete), затем нажмите OK.
  2. Нажмите кнопку Undo [image] на главной панели инструментов для возвращения элемента-фичера в модель.
  3. Нажмите кнопку Save [image] на главной панели инструментов и нажмите OK.
  4. Нажмите кнопку Файл > Закрыть Окно (File > Close Window) [image].

Note
Модели остаются в памяти сессии до тех пор, пока не будет выполнена команда Удалить ... из сессии (Erased).

Этим завершается первое упражнение.


Previous Page 19 of 76 Next
Упражнение 2: Создание моделей деталей.

Обзор - В этом упражнении будет изучаться моделирование простых деталей для получения навыков путем создания трех моделей:

  • PISTON_PIN.PRT
  • PISTON.PRT
  • CONNECTING_ROD.PRT

ПОРШНЕВОЙ ПАЛЕЦ (PISTON_PIN) и ПОРШЕНЬ (PISTON)

ШАТУН (CONNECTING_ROD)


Previous Page 20 of 76 Next
Information

Создание моделей деталей

Новые модели Деталей (Part) создаются на основе базового шаблона, который по умолчанию содержит базовые плоскости и координатную систему.

Базовые Плоскости по умолчанию (Default datum planes) обеспечивают 3 перпендикулярные плоскости в трехмерном пространстве, которые могут быть использованы как первоначальные привязки, когда создаются элементы-фичеры в модели.

Все базовые шаблоны в данном практикуме предполагают использование миллиметров.

Задача 2-1. Создание модели ПОРШНЕВОГО ПАЛЬЦА (PISTON_PIN) используя базовый шаблон.

  1. Нажмите кнопку Новый (New) [image] на главной панели инструментов и выберите Деталь (Part) в качестве Типа (Type). Напишите PISTON_PIN как Имя (Name) и нажмите ENTER.

Новая Модель Детали (Part)

  2. Нажмите кнопку Базовые оси (Datum Axes) [image], Базовые точки (Datum Points) [image] и Системы координат (Coordinate Systems) [image] на главной панели инструментов (сверху экрана) для выключения их отображения.


Previous Page 21 of 76 Next
Information

Создание эскизов (Sketches)

Эскиз (Sketch) это основная двухмерная (3D) фигура, используемая для создания элемента-фичера, и эта фигура создается на плоскости.

Однажды созданные, эскизы могут быть простым образом использованы для создания трехмерных (3D) элементов-фичеров.
Задача 2-2. Создание эскиза круга для использования его в создании основного тела модели.

  1. Нажмите кнопку Рисование (Sketch Tool) [image] на панели элементов-фичеров (справа на экране).
  2. Выберите базовую плоскость FRONT на модели и нажмите кнопку Эскиз (Sketch) в диалоговом окне Эскиз (Sketch).
  3. Нажмите кнопку Закрыть (Close) в диалоговом окне Привязки (References).
  4. Нажмите кнопку Базовые плоскости (Datum Planes) [image] на главной панели инструментов (сверху экрана) для отключения их отображения.
  5. Нарисуйте круг, как показано на следующем рисунке:
    • Нажмите кнопку Окружность (Circle) [image] на панели инструментов эскиза (справа от экрана).
    • Расположите указатель мыши в месте пересечения базовых плоскостей.
    • Кликните (левой кнопкой мыши) и образуется точка размещения центра окружности, передвиньте мышку в сторону, затем кликните снова.
    • Заметьте, что размер диаметра создался автоматически.
    • Нажмите кнопку Выбрать объекты (Select Items) [image] на панели инструментов эскиза (справа от экрана) для перехода в режим выбора объектов.
    • Дважды кликните на значении диаметра, введите 5 и нажмите ENTER.

Создание эскиза

    6. Нажмите кнопку Продолжить (Complete Sketch) [image] на панели инструментов эскиза (справа от экрана).
    7. Нажмите кнопку Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
    8. Нажмите кнопку Базовые плоскости (Datum Planes) [image] на главной панели инструментов для включения их отображения.


Previous Page 22 of 76 Next
Information

Использование инструмента Выдавливание (Extrude Tool)

Инструмент Выдавливание (Extrude Tool) позволяет брать эскиз и линейно выдавливать его для создания элемента-фичера.

Вы можете добавить материал вытягиванием (protrusion) или удалить материал вырезом (cut) в процессе работы инструмента Выдавливание (Extrude).

Задача 2-3. Создание вытягивания, используя предыдущий эскиз.

  1. Выберите эскиз (подсветка красным цветом), создайте элемент-фичер Вытягивание (Extrude) как показано на следующем рисунке:
    • Нажмите на кнопку инструмент Выдавливание (Extrude Tool) [image] на панели элементов-фичеров (справа на экране).
    • Потяните указатель (handle) (белый квадратик на желтой заготовке) до 4.
    • Нажмите на черную стрелку Опции Глубины (Depth Options Flyout) [image] на инструментальной панели (снизу экрана) и выберите ...в обе стороны... (Both Sides) [image].
    • Ведите 20 на инструментальной панели для задания глубины и нажмите ENTER.
    • Нажмите кнопку Вписать...в окно (Refit) [image] на главной панели инструментов (сверху экрана).
    • Нажмите кнопку Применить (Complete Feature) [image] на инструментальной панели (снизу экрана).

Элемент-фичер Выдавливание создан

  2. Нажмите кнопку Сохранить (Save) [image] на главной панели инструментов и нажмите OK.
  3. Выберите команду Файл > Закрыть Окно (File > Close Window) [image].


Previous Page 23 of 76 Next
Information

Создание ПОРШНЯ (PISTON)

ПОРШЕНЬ (PISTON) также начинает создаваться с использованием эскиза окружности, но он будет размещен на другой плоскости.

Задача 2-4. Создание PISTON.PRT и создание первого эскиза.

  1. Нажмите Новый (New) [image] на главной панели инструментов и выберите Деталь (Part) в качестве Типа (Type).
  2. Введите PISTON в как Имя (Name) и нажмите ENTER. Новая модель детали создалась из шаблона по умолчанию.
  3. Нажмите Рисование (Sketch Tool) [image] на панели элементов-фичеров (справа на экране).
  4. Выберите базовую плоскость TOP на модели, и нажмите Эскиз (Sketch) в диалоговом окне Эскиз (Sketch).
  5. Нарисуйте окружность (circle) как показано на следующем рисунке:
    1. Нажмите Закрыть (Close) в диалоговом окне Привязки (References).
    2. Нажмите Базовые плоскости (Datum Planes) [image] на главной панели инструментов (сверху экрана) для выключения их отображения.
    3. Нажмите Окружность (Circle) [image] на панели инструментов эскиза (справа от экрана).
    4. Кликните (левой кнопкой мыши) и образуется точка размещения центра окружности, передвиньте мышку в сторону, затем кликните снова.
    5. Нажмите Выбрать объекты (Select Items) [image] на панели инструментов эскиза (справа от экрана) для перехода в режим выбора объектов.
    6. Дважды кликните на значении диаметра, введите 21 и нажмите ENTER.

Создание эскиза

  6. Нажмите кнопку Продолжить (Complete Sketch) [image] на панели инструментов эскиза (справа от экрана).
  7. Нажмите кнопку Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
  8. Нажмите кнопку Базовые плоскости (Datum Planes) [image] на главной панели инструментов для включения их отображения.


Previous Page 24 of 76 Next

Information

Изменение Направления Выдавливания (Depth Direction)

Можно изменить направление создания элемента-фичера относительно эскизной плоскости, используя кнопку Направление Выдавливания (Change Depth Direction).

Задача 2-5. Использование предыдущего эскиза для создания первого элемента-фичера Вытягивание (Extrude).

  1. Выберите эскиз, создайте элемент-фичер Вытягивание (Extrude) как показано на следующем рисунке:
    • Нажмите на инструмент Выдавливание (Extrude Tool) [image] на панели элементов-фичеров (справа на экране).
    • Дважды кликните на значении глубины, введите 18.5 и нажмите ENTER.
    • Нажмите Направление Выдавливания (Change Depth Direction) [image] на инструментальной панели (снизу экрана) для изменения направления создания элемента-фичера в обратную сторону.
    • Нажмите Продолжить (Complete Sketch) [image] на панели инструментов эскиза.
Note
Шаг сдвига указателя (handle) на данный момент установлен в 1mm.

Элемент-фичер Выдавливание создан


Previous Page 25 of 76 Next
Information

Создание Группы (Group) элементов-фичеров

Следующий твердотельный элемент-фичер создан как Вытянутый Вырез (Extruded Cut) для создания пустоты в ПОРШНЕ (PISTON). Для того чтобы осуществить желаемую размерную схему при создании отверстия, этот эскиз будет размещен на базовой плоскости, построенной на расстоянии от верхней поверхности модели.

Для этого нужно нажать на инструмент Выдавливания (Extrude tool) и Приостановить (Pause) его. Перед этим элементом-фичером будет создана базовая плоскость и эскиз. Когда инструмент Выдавливания (Extrude tool) будет Возобновлен (Resumed) и завершен, система автоматически создаст Группу (Group) в дереве модели. Группа позволяет редактировать несколько элементов-фичеров и манипулировать ими сразу.

Задача 2-6. Запуск инструмента Выдавливания (Extrude tool) и создание базовой плоскости.

  1. Нажмите на инструмент Выдавливания (Extrude tool) [image] на панели элементов-фичеров (справа на экране).
  2. Нажмите Приостановить... (Pause Feature) [image] на инструментальной панели (снизу экрана).
    1. Заметьте, что инструментальноая панель становится неактивной (серой), показывая остановку работы.
  3. Нажмите на инструмент Базовая Плоскость (Datum Plane Tool) [image] на панели элементов-фичеров (справа на экране).
  4. Выберите базовую плоскость TOP на модели и произведите смещение указателя (handle) вниз на 2.
  5. Нажмите OK в диалоговом окне Базовая Плоскость (Datum Plane).

Базовая плоскость создана


Previous Page 26 of 76 Next
Information

Использование Осевых (Centerlines) в Эскизе (Sketch)

Осевые (Centerlines) помогают добиться симметрии в эскизе. Например, необходимо расположить прямоугольник симметрично, относительно вертикальных и горизонтальных привязок. Осевые отображаются желтой штрихпунктирной линией.

Задача 2-7. Эскиз на предыдущей базовой плоскости. Отрисовка симметричного прямоугольника.
  1. При выбранной базовой плоскости необходимо нажать Рисование (Sketch Tool) [image] на панели элементов-фичеров.
    1. Заметьте, что базовая плоскость DTM1 автоматически выбрана как Плоскость Эскиза (Sketching Plane).
    2. Нажмите Эскиз (Sketch) в диалоговом окне Эскиз (Sketch).
    3. Нажмите Закрыть (Close) в диалоговом окне Привязки (References).
    4. Нажмите Базовые плоскости (Datum Planes) [image] на главной панели инструментов (сверху экрана) для выключения их отображения.
    5. Нажмите Нет Скрытых (No Hidden) [image] а главной панели инструментов.
    6. Обратите внимание на две желтовато-коричневые штриховые линии - это и есть привязки эскиза. Нарисованная геометрия будет привязываться к этим привязкам.
  2. Нарисуйте осевые и прямоугольник как показано на следующем рисунке:
    • Нажмите черную стрелку на кнопке Типы линий (Line Types Flyout) [image] на панели инструментов эскиза (справа от экрана) и выберите Осевая (Centerline) [image].
    • Укажите два месторасположения на вертикальной привязке эскиза для отрисовки вертикальной осевой линии.
    • Нарисуйте другую осевую линию на горизонтальной привязке эскиза, как показано на рисунке слева.
    • Нажмите Прямоугольник (Rectangle) [image] на панели инструментов эскиза (справа от экрана).
    • Нажмите и получите точку месторасположения верхнего левого угла прямоугольника.
    • Позволяя прямоугольнику привязаться симметрично, Нажмите и получите точку месторасположения нижнего правого угла прямоугольника.

Рисование Осевых и прямоугольника

Note
Всегда используйте метод 'нажмите и получите', когда рисуете геометрию, так как в противном случае задержка нажатой левой кнопки мыши может привести к смещению геометрии.


Previous Page 27 of 76 Next
Information

Рисование Дуг (Arcs)

Инструмент Дуга (Arc) может создавать дуги как по трем точкам, так и касательными (тангенциальными) к объектам. В этой задаче будет создаваться Касательную Дугу (Tangent Arc).

Задача 2-8. Продолжение эскизирования для создания овальной формы. Эскизирование касательных дуг, используя прямоугольник как ориентир.

  1. Нажмите Дуга (Arc) [image] на панели инструментов эскиза (справа от экрана).
    • Нажмите на верхнюю правую вершину прямоугольника и получите начало дуги.
    • Сдвиньте указатель вправо от зеленого символа квадранта для продолжения дуги.
    • Нажмите на нижнюю правую вершину прямоугольника для завершения дуги.
    • При помощи команды Дуга (Arc) [image] нарисуйте похожую дугу слева прямоугольника (двигая указатель уже влево от зеленого символа квадранта).

Рисование касательных дуг

Note
Всегда используйте метод 'нажмите и получите', когда рисуете геометрию, так как в противном случае задержка нажатой левой кнопки мыши может привести к смещению геометрии.

  2. Нажмите среднюю кнопку мыши для остановки эскизирования и перехода в режим выбора объектов.
    1. Заметьте, что кнопка Выбрать Объекты (Select Items) [image] нажалась на панели инструментов эскиза.
    2. Нажмите клавишу CTRL и выберите две вертикальные линии прямоугольника.
    3. Нажмите правой и подождите , затем выберите команду Удалить (Delete).


Previous Page 28 of 76 Next
Information

Создание Размеров (Dimensions)

Много различных типов размеров можно создать инструментом Размер (Dimension). Для создания размера нужно выбрать элементы для образмеривания и нажать среднюю кнопку мыши для получения размера.

Задача 2-9. Завершите построение овальной формы образмериванием.

  1. Нажмите Размер (Dimension) [image] на панели инструментов эскиза (справа от экрана).
    • Выберите каждую из дуг, расположите указатель над эскизом, и нажмите среднюю кнопку мыши для размещения размера.
    • Выберите Гориз (Horiz) во всплывающем диалоговом окне Ориентация размера (Dim Orientation) и нажмите Принять (Accept).
    • После того как кнопка Размер (Dimension) [image] станет нажатой выберите верхнюю и нижнюю линии.
    • Расположите указатель справа от эскиза и нажмите среднюю кнопку мыши для размещения размера.
    • Нажмите среднюю кнопку мыши для остановки эскизирования и перехода в режим выбора объектов. Заметьте, что кнопка Выбрать Объекты (Select Items) [image] нажата.
    • Дважды кликните на горизонтальном размере, введите 18 и нажмите ENTER.
    • Дважды кликните на вертикальном размере, введите 12.5 и нажмите ENTER.

Создание размеров

  2. Нажмите Продолжить (Complete Sketch) [image] на панели инструментов эскиза.
  3. Нажмите кнопку Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
  4. Нажмите кнопку Базовые плоскости (Datum Planes) [image] на главной панели инструментов для включения их отображения.
  5. Нажмите Закраска (Shading) [image] на главной панели инструментов.


Previous Page 29 of 76 Next
Information

Получение Группы (Group) элементов-фичеров

Так как теперь созданы базовая плоскость и эскиз, можно нажать Возобновить (Resume) и завершить тем самым элемент-фичер Вытягивание (Extrude). Созданное отверстие сделает пустотелым ПОРШЕНЬ (PISTON).

Задача 2-10. Получение Вытянутого Выреза (cut) с использованием предыдущего чертежа.

  1. При выбранном эскизе завершите элемент-фичер Вытягивание (Extrude) как показано на следующем рисунке:
    • Нажмите Возобновить (Resume Feature) [image] на инструментальной панели.
    • Нажмите желтую стрелку направления на модели для изменения направления в обратную сторону.
    • Нажмите на черную стрелку Опции Глубины (Depth Options Flyout) [image] на инструментальной панели и выберите Через все (Through All) [image].
    • Нажмите Удаление материала (Remove Material) [image] на инструментальной панели и затем нажмите Применить (Complete Feature) [image].
    • Нажмите и удержите среднюю кнопку мыши для вращения модели и посмотрите на отверстие с другой стороны.
Tip
Много операций с элементами-фичерами можно сделать, нажимая правую кнопку мыши на указателях (handles) или нажимая на модели, а также используя иконки на инструментальной панели.

Вытянутый Вырез (Cut) создан


Previous Page 30 of 76 Next
Information

Автоматические Группы (Groups)

Базовая плоскость и эскиз автоматически группируются с элементом-фичером Вытягивание (Extrude). Эти дополнительные элементы автоматически делаются Скрытыми (Hidden), чтобы не вызывать беспорядка на экране. Скрытые элементы в дереве модели как бы прикрыты "серой пеленой".

Задача 2-11. Исследование созданной группы в дереве модели.

  1. Расположение группы ВЫТЯГИВАНИЕ_2 (EXTRUDE_2) в дереве модели.
    1. Заметьте, что элемент-фичер Вытянутый Вырез (Extruded Cut) был автоматически сгруппирован с базовой плоскостью и эскизом, используемым для определения.

Дерево модели


Previous Page 31 of 76 Next
Information

Создание линейных Отверстий (Holes)

Отверстия (Holes) удаляют материал с модели и имеют по умолчанию цилиндрическую форму.

Линейные отверстия требуют задать Первичную (Primary) и Вторичные (Secondary) привязки. Первичная привязка - это плоскость расположения отверстия; вторичные привязки - это привязки для расположения размеров.

Задача 2-12. Начало создания отверстия в центре ПОРШНЯ (PISTON).

  1. Нажмите Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
  2. Нажмите Отверстие (Hole Tool) [image] на панели элементов-фичеров и выберите базовую плоскость FRONT на модели.
    1. Нажмите правой и подождите, затем выберите Коллектор Вторичных Ссылок (Secondary References).
    2. Нажмите клавишу CTRL и выберите базовые плоскости TOP и RIGHT на модели для расположения размеров до отверстия.

Note

Заметьте, что нужно нажать и удерживать клавишу CTRL для выбора нескольких привязок.

  3. Продолжение создания отверстия - как показано на следующем рисунке:
    • Нажмите Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите FRONT.
    • Перетяните указатель (handle) расположения отверстия (в центре отверстия) на позицию, приблизительно показанную на рисунке слева.
    • Выберите закладку Размещение (Placement) на инструментальной панели, измените значения смещения
      от базовой плоскости TOP на 8 и нажмите ENTER.
    • Измените тип размера для базовой плоскости RIGHT со Смещать (Offset) на Выровнять (Align).

Позиционирование Отверстия (Hole)


Previous Page 32 of 76 Next
Задача 2-13. Завершение создания отверстия в центре ПОРШНЯ (PISTON).

  1. Завершите создание отверстия как показано на следующем рисунке:
    • Нажмите Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
    • Нажмите закладку Форма (Shape) на инструментальной панели.
    • Переключите опцию глубины с Глубины (Blind) на Насквозь (Through All).
    • Переключите опцию глубины для Стороны 2 (Side 2) с Нет (None) на Насквозь (Through All).
    • Введите 5 как диаметр на инструментальной панели и нажмите ENTER.
    • нажмите Продолжить (Complete Feature) [image].

Отверстие (Hole) создано

Tip
Можно нажать среднюю кнопку мыши для выполнения команды Продолжить (Complete Feature) [image].


Previous Page 33 of 76 Next
Information

Назначение Цвета (Color) на модель

Можно использовать диалоговое окно Цвет и Образ (Color and Appearance) для создания и назначения цветов для моделей. В этом случае базовая палитра цветов должна быть предварительно загружена.

Задача 2-14. Назначение вида цвета на модель.

  1. Нажмите Базовые плоскости (Datum Planes) [image] на главной панели инструментов для выключения их отображения.
  2. Нажмите Вид > Цвет и Образ (View > Color and Appearance) в главном меню.
    1. Выберите вид цвета Blue_Dark (третья сфера в верхней строке) и нажмите Применить (Apply).
    2. Нажмите Закрыть (Close) в диалоговом окне Редактор Образа (Appearance Editor).

Завершения ПОРШНЯ (PISTON)

  3. Нажмите Сохранить (Save) [image] на главной панели инструментов и нажмите OK.
  4. Нажмите Файл > Закрыть Окно (File > Close Window) [image].


Previous Page 34 of 76 Next
Information

Создание Шатуна (CONNECTING ROD)

Мы будем создавать тело Шатуна (CONNECTING_ROD), используя эскиз овальной формы и вытягивание.

Задача 2-15. Создание файла CONNECTING_ROD и начало эскизирования.

  1. Нажмите Базовые плоскости (Datum Planes) [image] на главной панели инструментов для включения их отображения.
  2. Нажмите Новый (New) [image] на главной панели инструментов и выберите Деталь (Part) в качестве Типа (Type).
    1. Введите CONNECTING_ROD в качестве Имени (Name) и нажмите ENTER
  3. Нажмите Рисование (Sketch Tool) [image] на панели элементов-фичеров.
    1. Выберите базовую плоскость FRONT на модели и нажмите Эскиз (Sketch) в диалоговом окне Эскиз (Sketch).
    2. Нажмите Закрыть (Close) в диалоговом окне Привязки (References).
    3. Нажмите Базовые плоскости (Datum Planes) [image] на главной панели инструментов для выключения их отображения.
  4. Начните построение овала с рисования двух кругов как показано на следующем рисунке:
    • Нажмите Осевая (Centerline) [image] на панели инструментов эскиза. Укажите два месторасположения на вертикальной привязке эскиза для отрисовки вертикальной осевой линии.
    • Нажмите Окружность (Circle) [image] на панели инструментов эскиза. Кликните на горизонтальной привязке для размещения центра левой окружности, затем завершите построение окружности.
    • Кликните на горизонтальной привязке для размещения центра правой окружности, затем смещайте мышь от центра окружности до тех пор, пока радиус этой окружности не привяжется к радиусу первой окружности, затем кликните снова для завершения построения окружности.
    • Нажмите Закрепления (Constraints) [image] на панели инструментов эскиза.
    • Нажмите Симметричность (Symmetric) [image] и выберите центр каждой окружности и потом осевую линию.
    • Нажмите Закрыть (Close) в диалоговом окне Закрепления (Constraints).

Рисование окружностей (Circles)


Previous Page 35 of 76 Next
Information

Касательные линии (Tangent Lines) и Динамическая Обрезка (Dynamic Trim)

Касательная Линия к двум объектам (2-Tangent Line) позволяет проще нарисовать линии, касательные к двум элементам.

Инструмент Динамическая Обрезка (Dynamic Trim) позволяет удалять ненужные части эскизных элементов. В этом случае кривая (curve), рисуется от руки и протягивается через эскиз, и любые элементы, пересекающиеся с ней, будут удалены.

Задача 2-16. Продолжение рисования овала для модели CONNECTING_ROD.

  1. Продолжите рисование как показано на следующем рисунке:
    • Нажмите черную стрелку на кнопке Типы линий (Line Types Flyout) [image] на панели инструментов эскиза и выберите Касательную Линию (2-Tangent Line) [image].
    • Позволяя указателю привязываться к окружностям, нарисуйте две горизонтальные линии, как показано на рисунке.

Рисование линий

  2. Нажмите Динамическая Обрезка (Dynamic Trim) [image] на панели инструментов эскиза.
    • Разместите указатель внутри одной из окружностей.
    • Нажмите и задержите левую кнопку мыши, затем протяните кривую линию через внутренние дуги для их удаления (любые элементы, пересеченные этой кривой будут удалены).

Обрезка завершена
Tip
Нажимайте Отменить (Undo) [image] и используйте Динамическую Обрезку (Dynamic Trim) [image] снова, если необходимо.


Previous Page 36 of 76 Next
Задача 2-17. Завершение рисования и создание симметричного Вытягивания (Extrude).

  1. Образмерьте эскиз как показано на следующем рисунке:
    • Нажмите Размер (Dimension) [image] на панели инструментов эскиза.
    • Выберите центр каждой дуги и нажмите среднюю кнопку мыши над эскизом для размещения горизонтального размера.
    • Дважды кликните на левую дугу и затем нажмите левую кнопку мыши слева от эскиза для размещения диаметрального размера.
    • Нажмите среднюю кнопку мыши для завершения рисования и перехода в режим выбора объектов.
    • Дважды кликните на размере диаметра, введите 8.5 и нажмите ENTER.
    • Дважды кликните на размере длины, введите 33 и нажмите ENTER.

Создание и модификация размеров (Dimensions)

  2. Нажмите Продолжить (Complete Sketch) [image] на панели инструментов эскиза.
  3. Нажмите кнопку Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
  4. Нажмите кнопку Базовые плоскости (Datum Planes) [image] на главной панели инструментов для включения их отображения.
  5. При выбранном эскизе создайте элемент-фичер Вытягивание (Extrude) как показано на следующем рисунке:
    • Нажмите на инструмент Выдавливание (Extrude Tool) [image] на панели элементов-фичеров.
    • Нажмите на черную стрелку Опции Глубины (Depth Options Flyout) [image] на инструментальной панели и выберите В Обе Стороны (Both Sides) [image].
    • Потяните указатель (handle) глубины до 3.
    • Нажмите Применить (Complete Feature) [image] на инструментальной панели.

Вытягивание завершено


Previous Page 37 of 76 Next
Information

Копирование существующей геометрии

Можно использовать инструмент Объект по Кромке (Entity from Edge) для копирования существующей геометрии. Созданные элементы будут 'приклеены' к существующей геометрии без необходимости образмеривания.

Задача 2-18. Начало создания второго чертежа путем копирования существующей геометрии.

  1. Нажмите Рисование (Sketch Tool) [image] на панели элементов-фичеров.
  2. Нажмите Прежняя (Use Previous) и нажмите Эскиз (Sketch) в диалоговом окне Эскиз (Sketch).
  3. Нарисуйте как показано на следующем рисунке:
    • Нажмите Закрыть (Close) в диалоговом окне Привязки (References).
    • Нажмите Базовые плоскости (Datum Planes) [image] на главной панели инструментов для выключения их отображения.
    • Нажмите Нет Скрытых (No Hidden) [image] на главной панели инструментов.
    • Нажмите Объект по Кромке (Entity from Edge) [image] на панели инструментов эскиза.
    • Выберите дуги и два прямых участка как показано на следующем рисунке.
    • Нажмите Закрыть (Close) в диалоговом окне Тип (Type).

Создание элементов по Кромкам


Previous Page 38 of 76 Next
Задача 2-19. Продолжение рисования эскиза и обрезка.
  1. Нажмите Линия (Line) [image] на кнопке Типы линий (Line Types Flyout) панели инструментов эскиза.
    • Нарисуйте вертикальную линию, привязанную к существующим линиям, и нажмите среднюю кнопку мыши для остановки эскизирования.
    • Нажмите Динамическая Обрезка (Dynamic Trim) [image] на панели инструментов эскиза.
    • Нажмите и протяните через эскиз кривую для удаления ненужных горизонтальных сегментов линий как показано на нижнем рисунке.
    • Проигнорируйте любые размеры на данный момент.

Рисование Линии (Line) и Динамическая Обрезка (Dynamic Trim)


Introduction to Pro/ENGINEER Wildfire 2.0.

Previous Page 39 of 76 Next
Задача 2-20. Образмеривание и завершение эскиза.
  1. Нажмите Размер (Dimension) [image] на панели инструментов эскиза.
    • Выберите дугу и вертикальную линию, затем нажмите среднюю кнопку мыши для размещения размера.
    • Нажмите среднюю кнопку мыши для остановки рисования и перехода в режим выбора объектов.
    • Дважды кликните на значении размере, введите 8 и нажмите ENTER.

Размер создан

  2. Нажмите Продолжить (Complete Sketch) [image] на панели инструментов эскиза.
  3. Нажмите кнопку Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
  4. Нажмите Закраска (Shading) [image] на главной панели инструментов.


Introduction to Pro/ENGINEER Wildfire 2.0.

Previous Page 40 of 76 Next
Задача 2-21. Создание вытягивания, формирующего расширение края модели.
  1. При выбранном эскизе нажмите Выдавливание (Extrude Tool) [image] на панели элементов-фичеров.
    • Нажмите на черную стрелку Опции Глубины (Depth Options Flyout) [image] на инструментальной панели и выберите В Обе Стороны (Both Sides) [image].
    • Потяните указатель (handle) глубины до 7.
    • Нажмите Применить (Complete Feature) [image] на инструментальной панели.
Tip
Можно нажать правую кнопку мыши на указателях (handles) глубины и выбрать желаемую опцию.

Вытягивание (Protrusion) Создано


Previous Page 41 of 76 Next
Information

Базовые Оси (Datum Axes)

Базовые Оси (Datum Axes) это линейные привязки (references), которые используются для создания других элементов-фичеров.

Задача 2-22. Создание базовой оси (datum axis) и завершение создания модели.

  1. Нажмите Базовые Оси (Datum Axes) [image] на главной панели инструментов (сверху экрана) для включения их отображения.
  2. Нажмите инструмент Базовая Ось (Datum Axis Tool) [image] на панели элементов-фичеров (справа от экрана).
  3. Выберите цилиндрическую поверхность как показано на следующем рисунке и нажмите OK в диалоговом окне (Datum Axis).

Создание Базовой Оси (Datum Axis)


Previous Page 42 of 76 Next
Information

Соосные Отверстия (Coaxial Holes)

Соосные Отверстия (Coaxial Holes) используют базовые оси (datum axis) для центрирования, но также есть необходимость в дополнительной плоскости размещения, как вторичной привязке (secondary reference).

Задача 2-23. Создание соосного отверстия на предыдущей оси.

  1. При выбранной оси нажмите инструмент Отверстие (Hole Tool) [image] на панели элементов-фичеров.
    • Нажмите правой и подождите, затем выберите Коллектор Вторичных Ссылок (Secondary References).
    • Выберите поверхность "D-формы", показанную в верхнем левом углу, как плоскость размещения.
    • Нажмите правой кнопкой мыши на указателе (handle) глубины и задержите, затем выберите Насквозь (Through All).
    • Заметьте, что размер диаметра сохранился от предыдущего отверстия в значении 5 .
    • Нажмите Продолжить (Complete Sketch) [image] на панели инструментов эскиза.

Создание Отверстия (Hole)

  2. Нажмите Базовые оси (Datum Axes) [image] на главной панели инструментов для выключения их отображения.


Previous Page 43 of 76 Next

Information

Выбор нескольких привязок для Скругления (Round)

Нажимайте CTRL для выбора нескольких кромок под простое скругление (single round).

Задача 2-24. Создание скругления (round) для усиления края модели.
  1. Нажмите Скругления (Round Tool) [image] на панели элементов-фичеров.
    • Нажмите CTRL и выберите две внутренние кромки как показано на следующем рисунке.
    • Перетяните указатель (handle) одного из двух радиусов до 3.
    • Нажмите Продолжить (Complete Feature) [image] на инструментальной панели.

Создание Скругления (Round)


Previous Page 44 of 76 Next
Information

Зеркальное отражение (Mirroring) элементов-фичеров

Можно использовать инструмент Зеркальное отражение (Mirror) для зеркального отражения одного или нескольких элементов-фичеров относительно выбранной плоскости.

Задача 2-25.Отражение ряда элементов-фичеров для быстрого создания противоположной стороны модели CONNECTING_ROD.

  1. Нажмите CTRL и выберите следующие четыре элемента-фичера, начиная с низа Дерева Модели (Model Tree) (слева экрана).

Выбор элементов-фичеров

  2. Нажмите Зеркальное отражение (Mirror Tool) [image] на панели элементов-фичеров (справа на экране).
  3. Выберите базовую плоскость RIGHT на Дереве Модели (Model Tree) (слева экрана).
  4. Нажмите Продолжить (Complete Feature) [image] на панели управления.

Элементы-фичеры отражены
Note
Pro/ENGINEER Wildfire имеет специальные инструменты для быстрого дублирования элементов-фичеров; в них входят Зеркальное отражение (Mirror), Копировать/Вставить (Copy/Paste) и Массив (Pattern).

  5. Нажмите Сохранить (Save) [image] на главной панели инструментов и нажмите OK.
  6. Нажмите Файл > Закрыть Окно (File > Close Window) [image].

Этим завершается второе упражнение.


Previous Page 45 of 76 Next
Урок 3: Создание Сборок (Assemblies).

Обзор - В этом уроке приобретаются навыки моделирования простой сборки (assembly) путем создания сборки и запуска простого механизма (mechanism):

  • PISTON_ASSY.ASM
  • ENGINE.ASM

Сборка ПРОШНЯ (PISTON_ASSY Assembly)

Сборка ДВИГАТЕЛЯ (ENGINE Assembly)


Previous Page 46 of 76 Next
Information

Создание модели Сборки (Assembly)

Новые модели Сборок (Assembly) создаются на основе базового шаблона, который по умолчанию содержит базовые плоскости и координатную систему.

Первый компонент в сборке обычно размещается в позицию По Умолчанию (Default), при которой компонент центрируется в сборке.

Задача 3-1. Создание модели сборки PISTON_ASSY и добавление детали ПОРШЕНЬ (PISTON).

  1. Нажмите Базовые Плоскости (Datum Planes) [image] на главной панели инструментов для включения их отображения.
  2. Нажмите Новый (New) [image] и выберите Сборка (Assembly) в качестве Типа (Type).
  3. Введите PISTON_ASSY в качестве Имени (Name) т нажмите ENTER. Новая модель сборки создалась из базового шаблона.
  4. Нажмите Добавить Компонент (Add Component) [image] на панели элементов-фичеров (справа на экране).
    1. Выберите PISTON.PRT и нажмите Открыть (Open).
    2. Нажмите Позиция по Умолчанию (Default Location) [image] в диалоговом окне Размещение Компонента (Component Placement) и нажмите OK.
  5. Нажмите CTRL и выберите базовые плоскости ASM_RIGHT, ASM_TOP и ASM_FRONT на Дереве Модели (Model Tree).
    1. Нажмите правую и подождите, затем нажмите Скрыть (Hide).

PISTON.PRT добавлен в сборку


Previous Page 47 of 76 Next
Information

Сборка с помощью Привязок (Constraints)

Можно соединять компоненты сборки вместе, создавая различные типы Привязок (Constraints). Привязки могут быть использованы для сборки компонентов в зафиксированную позицию.

Привязки могут быть созданы выбором соответствующих пар геометрии компонента, который добавляется в сборку и компонента, существующего в сборке.

Задача 3-2. Добавление в сборку модели PISTON_PIN с привязками (constraints) Выровнять (Align) и Вставить (Insert).

  1. Нажмите Добавить компонент (Add component) [image] на панели элементов-фичеров.
    1. Выберите модель PISTON_PIN.PRT и нажмите Открыть (Open).
    2. Выберите базовую плоскость FRONT на модели PISTON и модели PISTON_PIN как показано на следующем рисунке.
    3. Заметьте, что получилась привязка Выровнять (Align) в диалоговом окне.

Выбор базовых плоскостей

  2. В случае необходимости, перетяните диалоговое окно Размещение Компонента (Component Placement) вниз для доступа к главной панели инструментов.
  3. Нажмите Базовые Плоскости (Datum Planes) [image] на главной панели инструментов для выключения их отображения.
  4. Выберите цилиндрические поверхности на моделях PISTON.PRT и PISTON_PIN.PRT как показано на следующем рисунке.
    1. Заметьте, что получилась привязка Вставить (Insert) в диалоговом окне.
    2. Нажмите OK в диалоговом окне Размещение Компонента (Component Placement).

Выбор цилиндрических поверхностей


Previous Page 48 of 76 Next
Information

Сборка с помощью Соединений (Connections)

Можно соединять компоненты сборки вместе, создавая различные типы Соединений (Connections). Привязки могут быть использованы для создания реалистичных механических соединений (joints) между компонентами. Эти соединения позволяют компонентам сборки двигаться как механизм.

Соединения могут быть созданы выбором соответствующих пар геометрии компонента, который добавляется в сборку и компонента, существующего в сборке.

Соединение Ось (Pin) позволяет вращать компонент, но не перемещать вдоль оси вращения.

Задача 3-3. Начало сборки модели CONNECTING_ROD с соединением типа Ось (Pin).

  1. Нажмите Добавить компонент (Add component) [image] на панели элементов-фичеров.
    1. Выберите модель CONNECTING_ROD.PRT и нажмите Открыть (Open).
    2. Выберите закладку Соединить (Connect) в диалоговом окне Размещение Компонента (Component Placement).
    3. Заметьте, что по умолчанию установлено соединение Ось (Pin).
    4. Нажмите и удерживайте среднюю кнопку мыши для вращения сборки, и затем выберите цилиндрические поверхности как показано на следующем рисунке.

Выбор цилиндрических поверхностей

  2. Нажмите Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).


Previous Page 49 of 76 Next
Information

Использование Инструмента Поиска (Search Tool)

Инструмент поиска (Search Tool) обеспечивает легкий способ выбора элементов, которые не отображаются.

В нашем случае базовые плоскости должны быть выбраны для выравнивания модели CONNECTING_ROD с центром модели PISTON.

Задача 3-4. Завершение соединения типа Ось (Pin) модели CONNECTING_ROD.

  1. Поиск первой базовой плоскости:
    1. Нажмите Инструмент поиска (Search Tool) [image] на главной панели инструментов.
    2. Выберите Базовая Плоск (Datum Plane) в выпадающем списке "Искать для" (Look For).
    3. Выберите модель PISTON.PRT в выпадающем списке "Просмотр в" (Look In).
    4. Нажмите Поиск (Find Now), выберите базовую плоскость FRONT и нажмите Добавить (Add Item) [image].
    5. Нажмите Закрыть (Close).
  2. Поиск второй базовой плоскости:
    1. Нажмите Инструмент поиска (Search Tool) [image] на главной панели инструментов снова и нажмите Поиск (Find Now).
    2. Выберите базовую плоскость FRONT и нажмите Добавить (Add Item) [image], затем нажмите Закрыть (Close).
    3. Теперь соединение типа Ось (Pin) определено. Нажмите OK в диалоговом окне Размещение Компонента (Component Placement).
  3. Нажмите Переместить Компонент (Drag Component) [image] на главной панели инструментов.
    1. Нажмите и получите двигающееся соединение тяги как показано на рисунке ниже.
    2. Кликните для принятия нового положения.
    3. Нажмите среднюю кнопку мыши, когда закончите.

PISTON_ASSY.ASM

  4. Нажмите Сохранить (Save) [image] на главной панели инструментов и нажмите OK.
  5. Нажмите Файл > Закрыть Окно (File > Close Window) [image].


Previous Page 50 of 76 Next
Задача 3-5. Открытие сборки модели ДВИГАТЕЛЯ (ENGINE).
  1. Нажмите Навигатор Папок (Folder Browser) [image] (слева экрана) и выберите папку ProE_models.
  2. Выберите модель ENGINE.ASM из браузера и нажмите Открыть файл в Pro/E (Open File in Pro/E) [image].

Note
Модель ENGINE_BLOCK.PRT должна быть прозрачной внутри сборки ENGINE.ASM.

ENGINE.ASM


Previous Page 51 of 76 Next
Information

Запуск Механизма (Mechanism)

Механизм (Mechanism) ссылается на компоненты, которые были собраны при помощи Соединений (Connections). Соединения (Connections) могут быть использованы для разрешения движения компонентов, похожему на реалистичное.

Вы можете выбрать Режим Механизма (Mechanism Mode) для того, чтобы запустить механизм. Для запуска его надлежащим образом, сборка должна иметь компоненты собранные с помощью соединений, а также необходимо определить Сервопривод (Servo Motor) и Анализ (Analysis).

Сервопривод (Servo Motor) определяет скорость вращения коленчатого вала (crankshaft), а Анализ (Analysis) определяет время вращения запущенного механизма.

Сборка ДВИГАТЕЛЯ (ENGINE) создавалась с использованием соединения типа Ось (Pin) для модели КОЛЕНВАЛ (CRANKSHAFT). Сервопривод (Servo Motor) (90 градусов/сек) и Анализ (Analysis) (4 сек) были созданы до Вас, и обеспечивают вращение на 360 градусов.

Задача 3-6. Запуск существующего механизма.

  1. Нажмите Приложения > Механизм (Applications > Mechanism) в главном меню.
    1. Нажмите Выполнить Анализ (Run Analysis) [image] на панели инструментов Механизма (справа на экране).
    2. Выберите имя RUN_ENGINE и нажмите Выполнить (Run).
    3. Заметьте, что КОЛЕНВАЛ (CRANKSHAFT) прокрутился на 360 градусов.
    4. Нажмите Закрыть (Close) в диалоговом окне Анализы (Analyses).
  2. Нажмите Приложения > Стандартное (Applications > Standard) в главном меню.
    1. Нажмите Да (Yes) в появившемся окне сообщений.
  3. Нажмите Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).


Previous Page 52 of 76 Next

Information

Сборка с помощью Соединений (Connections)

Цилиндрическое (Cylinder) соединение позволяет вращать и перемещать компонент вдоль оси (axis) вращения.

Задача 3-7. Добавление модели PISTON_ASSY в сборку ДВИГАТЕЛЯ (ENGINE), затем создание Цилиндрического (Cylinder) соединения.

  1. Нажмите Добавить компонент (Add component) [image] на панели элементов-фичеров.
  2. Выберите модель PISTON_ASSY.ASM и нажмите Открыть (Open).
  3. Создайте цилиндрическое соединение как показано на следующем рисунке:
    • Нажмите совместно CTRL + ALT, затем нажмите и задержите правую кнопку мыши для перемещения модели PISTON_ASSY.ASM в положение, показанное на рисунке.
    • Выберите закладку Соединить (Connect) в диалоговом окне Размещение Компонента (Component Placement).
    • Измените Тип (Type) соединения с Ось (Pin) на Цилиндрический (Cylinder).
    • Выберите цилиндрические поверхности как показано на рисунке.

Выбор поверхностей


Previous Page 53 of 76 Next
Задача 3-8. Создание второго цилиндрического соединения в модели PISTON_ASSY.
  1. Создайте цилиндрическое соединение как показано на следующем рисунке:
    • Нажмите и задержите среднюю кнопку мыши для поворота всей сборки как показано на рисунке сверху слева.
    • Нажмите CTRL, нажмите и удерживайте среднюю кнопку мыши, и передвиньте мышь к себе для приближения вида.
    • Нажмите совместно CTRL + ALT, затем нажмите и задержите левую кнопку мыши для перемещения модели CRANKSHAFT (КОЛЕНВАЛ) в положение, показанное на рисунке сверху справа.
    • Нажмите Новое Закрепление (New Constraint) [image] в диалоговом окне Размещение Компонента (Component Placement).
    • Увеличьте модель и выберите цилиндрические поверхности как показано на рисунке снизу.

Выбор поверхностей

  2. Нажмите совместно CTRL + ALT, затем нажмите и задержите левую кнопку мыши для перемещения модели CRANKSHAFT (КОЛЕНВАЛ) снова.
    1. Ось модели CRANKSHAFT (КОЛЕНВАЛ) может теперь выравниваться с отверстием в модели CONNECTING_ROD, и модель PISTON_ASSY может теперь вращаться совместно с CRANKSHAFT (КОЛЕНВАЛОМ).
    2. Нажмите OK в диалоговом окне Размещение Компонента (Component Placement).
    3. Нажмите Список сохраненых видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).

Соединения (Connections) завершены


Previous Page 54 of 76 Next
Information

Запуск Механизма (Mechanism)

Вы можете выбрать Режим Механизма (Mechanism Mode) для того, чтобы запустить механизм. После того, как модель PISTON_ASSY была собрана с использованием соединений, можно посмотреть вращение КОЛЕНВАЛА (CRANKSHAFT).

Задача 3-9. Запуск механизма ДВИГАТЕЛЯ (ENGINE) снова.

  1. Нажмите Приложения > Механизм (Applications > Mechanism) в главном меню
    1. Нажмите Выполнить Анализ (Run Analysis) [image] на панели инструментов Механизма (справа на экране).
    2. Выберите имя RUN_ENGINE и нажмите Выполнить (Run). Заметьте, что механизм прокрутился на 360 градусов.
    3. Нажмите Закрыть (Close) в диалоговом окне Анализы (Analyses).
  2. Нажмите Сохранить (Save) [image] на главной панели инструментов и нажмите OK.
  3. Нажмите Файл > Закрыть Окно (File > Close Window) [image] и нажмите Да (Yes) в появившемся окне сообщений.
  4. Нажмите Файл > Стереть > Невидимые > OK (File > Erase > Not Displayed > OK) для стирания всех моделей из памяти сессии.

Этим завершается третье упражнение.


Previous Page 55 of 76 Next

ПОЗДРАВЛЯЕМ !

Вы завершили раздел по моделированию деталей и сборок этого учебника.

Если Вы желаете, то, пожалуйста, продолжите вторую часть упражнений, бросив вызов:

  • Созданию Чертежей (Drawings) (10 страниц)
  • Ассоциативности Модели (Model Associativity) (5 страниц)

РЕЗЮМЕ

Теперь заметим, что Вы завершили эту секцию учебника и способны:

  • Описать основы Pro/ENGINEER Wildfire.
  • Управлять интерфейсом Pro/ENGINEER Wildfire.
  • Делать предпросмотр, открытие и ориентацию разработанных моделей.
  • Создавать простые модели деталей.
  • Создавать сборку.
  • Запускать простой механизм.


Previous Page 56 of 76 Next
Упражнение 4: Создание Чертежей (Drawings) (ВЫЗОВ).

ОБЗОР - в этом упражнении приобретаются навыки создания простого чертежа (drawing) путем создания 2-х листового чертежа, названного ENGINE_COMPONENTS; разброс по деталям сборки ДВИГАТЕЛЯ (ENGINE) и ШАТУНА (CONNECTING_ROD):

  • ENGINE_COMPONENTS.DRW - лист 1 (sheet 1)
  • ENGINE_COMPONENTS.DRW - лист 2 (sheet 2)

Чертеж ENGINE_COMPONENTS.DRW - лист 1 и 2 (sheet 1 and 2)


Previous Page 57 of 76 Next
Задача 4-1. Открытие сборки ENGINE_COMPLETE.
  1. Выберите закладку Навигатор Папок (Folder Browser) [image] и выберите папку ProE_models.
  2. Выберите модель ENGINE_COMPLETE.ASM в браузере и нажмите Открыть в Pro/E (Open File in Pro/E) [image].

ENGINE_COMPLETE.ASM


Previous Page 58 of 76 Next
Information

Сечения (Cross Sections)

Существует два различия между моделью ENGINE_COMPLETE.ASM и тем, что было создано Вами: в отрытой модели уже созданы Сечение (Cross Section) и Разнесенный Вид (Explode State). Они будут использоваться для создания чертежа.

Сечения (Cross Sections) позволяют определять "разрез" детали или сборки на виде.

Задача 4-2. Исследование сечения сборки ENGINE_COMPLETE.

  1. Нажмите Менеджер Видов (View Manager) [image] на главной панели инструментов.
    • Выберите закладку Сечения (Xsec) и дважды нажмите на A для обзора сечения.
    • Нажмите Отображение > Поворот (Display > Flip) в диалоговом окне Менеджер Видов (View Manager).
    • Дважды нажмите на Нет Сечения (No Cross Section).

Сечение А (Cross Section A)


Previous Page 59 of 76 Next
Information

Разнесенные виды (Explode States)

Существует два различия между моделью ENGINE_COMPLETE.ASM и тем, что было создано Вами: в отрытой модели уже созданы Сечение (Cross Section) и Разнесенный Вид (Explode State). Они будут использоваться для создания чертежа.

Разнесенные виды (Explode States) позволяют определить "разобранный" вид сборки.

Задача 4-3. Исследование разнесенного вида в сборке ENGINE_COMPLETE.

  1. В диалоговом окне Менеджер Видов (View Manager) выберите закладку Разнесенный (Explode).
    • Дважды нажмите на Exp_1 для обзора разнесенного вида.
    • Нажмите правой кнопкой мыши в диалоговом окне Менеджер Видов (View Manager) и выберите Собрать (Unexplode).
    • Нажмите Закрыть (Close) в диалоговом окне Менеджер Видов (View Manager).

Разнесенный вид Exp_1


Previous Page 60 of 76 Next
Information

Создание Чертежей (Drawings)

Режим Чертежа (Drawing) позволяет размещать плоские и аксонометрические (2D и 3D) виды модели детали или сборки на плоском (2D) чертежном листе для производственных целей.

Можно быстро создавать чертежи, использую Чертежный Шаблон (Drawing Template). Чертежный Шаблон (Template) содержит предопределенное расположение видов и может содержать форматку с титульным блоком.

Этот специфический шаблон может быть использован в различных комбинациях сборок с похожими результатами.

Задача 4-4. Создание чертежа сборки ENGINE_COMPLETE с использованием шаблона.

  1. Нажмите Файл > Закрыть Окно (File > Close Window) [image].
  2. Нажмите Новый (New) [image] и выберите Чертеж (Drawing) в качестве Типа (Type).
  3. Введите ENGINE_COMPONENTS в качестве Имени (Name) и нажмите ENTER.
  4. Заметьте, что ENGINE_COMPLETE.ASM используется как Модель По Умолчанию (Default Model), и что текущим шаблоном является drawing_template.
  5. Нажмите OK в диалоговом окне Новый Чертеж (New Drawing).
  6. Введите информацию параметра для создания чертежа как показано на следующем рисунке:
    • Введите Ваше Имя (YOUR NAME) на запрос и нажмите ENTER.
    • Создался новый чертеж, который использует шаблон для размещения 4 изометрических видов, разнесенный вид, титульный блок и спецификацию (bill of materials - BOM).
    • Дважды нажмите на графу с датой (date) в титульном блоке напротив Вашего имени и введите &todays_date.
    • Нажмите OK в диалоговом окне Свойства Заметки (Note Properties).
Note
Слово '&todays_date' ("текущая дата") использует системный параметр для отображения даты.

Чертеж создан


Previous Page 61 of 76 Next
Information

Создание Чертежей (Drawings)

В дополнение к используемому чертежному Шаблону (Template) можно размещать виды на листе чертежа вручную. Сначала размещается Общий (General) вид. Общий (General) вид может быть размещен в любой ориентации.

Задача 4-5. Добавление второго листа и создание вида модели CONNECTING_ROD.

  1. Нажмите на фон чертежа, затем нажмите правую кнопку мыши и выберите Свойства (Properties).
    1. Нажмите Модели Чертежа > Добав Модель (Drawing Models > Add Model) в менеджере меню (справа от экрана).
    2. Выберите модель CONNECTING_ROD_COMPLETE.PRT и нажмите Открыть (Open).
  2. Нажмите Вставить > Лист (Insert > Sheet) в главном меню для добавления второго листа в чертеж.
    1. Введите Ваше Имя (YOUR NAME) на запрос и нажмите ENTER.
  3. Нажмите правую кнопку мыши и выберите Вставить Общий Вид (Insert General View).
    1. Выберите точку расположения как показано на следующем рисунке для размещения вида.

Размещение Общего Вида (General View).

  4. Выберите FRONT(фронтальный) в качестве Имени Вида Модели (Model View Name) и нажмите OK в диалоговом окне Вид Чертежа (Drawing View).
  5. Дважды кликните на тексте МАСШТАБ (SCALE) в нижнем левом углу листа, введите 5 и нажмите ENTER.


Previous Page 62 of 76 Next
Information

Создание Чертежей (Drawings)

Поскольку Общий (General) вид размещен, можно создавать другие виды, например Проекционные (Projection) виды.

Задача 4-6. Размещение проекционных видов CONNECTING_ROD.

  1. Создайте проекционный вид как показано на следующем рисунке:
    • Выберите предыдущий вид FRONT (фронтальный).
    • Нажмите правую кнопку мыши и выберите Вставить Проекционный Вид (Insert Projected View).
    • Выберите расположение над первым видом как показано на следующем рисунке.

Размещение первого Проекционного Вида (Projection View)

  2. Создайте другой проекционный вид как показано на следующем рисунке:
    • Выберите вид FRONT (фронтальный) снова.
    • Нажмите правую кнопку мыши и выберите Вставить Проекционный Вид (Insert Projected View).
    • Выберите расположение справа первого вида как показано на следующем рисунке.

Размещение второго Проекционного Вида (Projection View)


Previous Page 63 of 76 Next
Information

Создание Чертежей (Drawings)

Общие (General) виды могут быть расположены в 2D или 3D ориентациях.

Задача 4-7. Размещение 3D общего вида модели CONNECTING_ROD.

  1. Нажмите на фон для снятия выбора с текущего вида.
  2. Нажмите правую кнопку мыши и выберите Вставить Проекционный Вид (Insert Projected View).
    • Выберите точку расположения как показано на следующем рисунке для размещения вида.
    • Нажмите OK в диалоговом окне Вид Чертежа (Drawing View).
    • Нажмите правую кнопку мыши и выберите Блокировать Движение Видов (Lock View Movement) чтобы снять галочку.
    • Выберите и перетяните виды, в случае необходимости, в позицию, показанную на рисунке.

Размещение 3D Общего Вида.


Previous Page 64 of 76 Next
Information

Стили Показа (Display Style) вида

Вы можете изменить Стиль Показа (Display Style) вида, вызвав Свойства (Properties) вида. Стили Показа (Display Styles) вида содержат режимы отображения: Нет Скрытых (No Hidden), Скрытые Линии (Hidden Lines) и Каркасный (Wireframe).

Задача 4-8. Установите стиль показа для видов TOP (верхний) и RIGHT (правый) в режим отображения скрытых линий (hidden lines).

  1. Нажмите на фон для снятия выбора с текущего вида, в случае необходимости.
  2. Установите стиль показа для двух видов:
    1. Нажмите CTRL и выберите проекционные виды TOP (верхний) и RIGHT (правый).
    2. Нажмите правую кнопку мыши и выберите Свойства (Properties). Выберите тип Скрытые (Hidden) в качестве Стиля Показа (Display Style) и нажмите OK.

Скрытые линии (Hidden Lines) отобразились


Previous Page 65 of 76 Next
Information

Отображение размеров (Dimensions)

Можно быстро Показать Размеры (Show Dimensions), созданные в модели детали. Размеры создавались в процессе моделирования элементов-фичеров; это размеры эскиза или размер глубины отверстия, введенный позже.

Задача 4-9. Показ и упорядочивание размеров на видах FRONT (фронтальный) и TOP (верхний).

  1. Выберите вид FRONT (фронтальный), затем нажмите правую и выберите Показать Размеры (Show Dimensions).
  2. Нажмите CTRL, нажмите и удерживайте среднюю кнопку мыши, и передвиньте мышь к себе для приближения вида.
  3. Выберите размер 8, затем передвиньте его на место, показанное на следующем рисунке.

Размер передвинут


Previous Page 66 of 76 Next
Information

Упорядочивание (Cleaning Up) размеров

Можно быстро Упорядочить Размеры (Cleanup Dimensions) на виде, после того как они будут показаны. Это дистанцирует их относительно вида. Только линейные размеры могут быть упорядочены.

Задача 4-10. Показ и упорядочивание размеров на видах FRONT (фронтальный) и TOP (верхний).

  1. Нажмите на вид FRONT (фронтальный), затем нажмите правую и выберите Упорядочить Размеры (Cleanup Dimensions).
    1. Введите по 0.5 в графы Смещение (Offset) и Приращение (Increment) в диалоговом окне Упорядочить Размеры (Clean Dimensions).
    2. Снимите галочку в пункте Создать Линии Привязки (Create Snap Lines) и нажмите Применить > Закрыть (Apply > Close).
  2. Нажмите Вписать (Refit) [image] на главной панели инструментов.
  3. Выберите вида TOP (сверху), нажмите правую и выберите Показать Размеры (Show Dimensions).
  4. Нажмите правую снова и выберите Упорядочить Размеры (Cleanup Dimensions).
  5. Нажмите Применить > Закрыть (Apply > Close).


Previous Page 67 of 76 Next
Information

Управление Размерами

Поскольку размеры показаны и упорядочены, можно дополнительно манипулировать ими. Когда размер выбран, появляется несколько указателей (handles) управления ими:

  • Указатель (Handle) в центре текста - Сместить размер.
  • Любой из указателей (Handles) в стороне от текста - Смещение размерного текста.
  • Указатели (Handles) на концах вспомогательных линий - Выравнивание выносных линий.

Несколько опций редактирования дополнительных размеров также доступны после выбора размера (-ов) и вызываются из меню по правой кнопке мыши.

Задача 4-11. Управление размерами на видах FRONT (фронтальный) и TOP (верхний).

  1. Разместите указатель мыши между видами FRONT (фронтальный) и TOP (верхний).
    1. Нажмите CTRL, нажмите и удерживайте среднюю кнопку мыши, и передвиньте мышь к себе для приближения вида.
  2. Управляйте размерами как показано на следующем рисунке:
    • Выберите диаметральный размер 8.5, нажмите правой и выберите Повернуть Стрелки (Flip Arrows).
    • Выберите диаметральный размер 5, нажмите правой и выберите Повернуть Стрелки (Flip Arrows). Затем перетяните размер в позицию, показанную на рисунке. Перетяните указатель (handle), расположенный за размерным текстом для перемещения текста налево от выноски.
    • Выберите размер 8. Нажмите и перетяните указатели (handles) на концах выносных линий в позицию, показанную на рисунке.
    • Выберите радиусный размер 3. нажмите правой и выберите Повернуть Стрелки (Flip Arrows) дважды. Затем перетяните размер в позицию, показанную на рисунке. Перетяните указатель (handle), расположенный за размерным текстом для перемещения текста направо от выноски.
    • Выберите размер 7. Нажмите и перетяните указатели (handles) на концах выносных линий в позицию, показанную на рисунке.

Размеры перепозиционированы


Previous Page 68 of 76 Next
Information

Создание размеров

Можно использовать опцию Создать размер (Create Dimension) для создания размера на чертеже для геометрии, которая не образмерена.

Созданный таким образом размеры часто обозначается как Справочный (Driven) размер, поскольку он управляется геометрией и обновляется при изменении, но не может быть напрямую отредактирован.

Задача 4-12. Создание размера для обозначения габаритной длины модели CONNECTING_ROD.

  1. Нажмите Создать размер (Create Dimension) [image] на панели инструментов чертежа.
    1. Выберите кромки как показано на следующем рисунке.

Выбор Кромок (Edges)

  2. Нажмите среднюю кнопку мыши над размером 33 для размещения размера.
    1. Нажмите Касательно > Касательно > Горизонтальный > Вернуться (Tangent > Tangent > Horizontal > Return) в менеджере меню (справа от экрана).

Справочный (Driven) размер создан

  3. Нажмите на вид FRONT (фронтальный), нажмите правую и выберите Упорядочить размеры (Cleanup Dimensions).
    1. Нажмите Применить > Закрыть (Apply > Close). Заметьте, что созданный размер дистанцировался соответствующим образом.
  4. Нажмите Вписать (Refit) [image] на главной панели инструментов.
  5. Нажмите Сохранить (Save) [image] и затем нажмите OK.
  6. Нажмите Файл > Закрыть Окно (File > Close Window) [image].

Этим завершается четвертое упражнение.


Previous Page 69 of 76 Next
Упражнение 5: Ассоциативность (Associativity) модели (ВЫЗОВ).

Обзор - В этом упражнении Вы будете экспериментировать с ассоциативностью между режимами деталь, сборка и чертеж. Ассоциативность (Associativity) позволяет проводить изменения в одном из режимов, для того чтобы изменения отразились в других режимах. Вы будете выполнять следующие задачи:

  • Модификация модели детали и просмотр обновления сборки.
  • Исследование взаимопроникновения (interference) деталей в сборке.
  • Модификация размера в чертеже и просмотр обновления детали.
  • Пересмотр сборки для проверки разрешения ситуации с взаимопроникновением (interference) .


Previous Page 70 of 76 Next
Задача 5-1. изменение размера тела модели CONNECTING_ROD для ее удлинения.
  1. Выберите Навигатор Папок (Folder Browser) [image] и выберите папку ProE_models.
    1. Выберите модель ENGINE_COMPLETE.ASM из браузера и нажмите Открыть Файл в Pro/E (Open File in Pro/E) [image].
Note
ВАЖНО - следующим шагом Вы будете открывать второе окно Pro/ENGINEER. Вы должны изменить размеры и положение окна справа от учебника.

  2. Нажмите '+' для раскрытия модели PISTON_ASSY_COMPLETE в дереве модели.
    1. Выдерите модель CONNECTING_ROD_COMPLETE.
    2. Нажмите правой и подождите, затем нажмите Открыть (Open).
  3. Дважды кликните на середину модели для отображения размеров элемента-фичера ВЫТЯГИВАНИЕ 1 (EXTRUDE 1).
  4. Дважды кликните на размере 33, введите 30 и нажмите ENTER.

Редактирование размера

  5. Нажмите Обновить (Regenerate) [image] на главной панели инструментов для обновления модели.
    Tip
            Также можно нажать совместно CTRL + G для регенерации модели.


Previous Page 71 of 76 Next
Задача 5-2. Регенерация сборки для обзора эффекта сокращения модели CONNECTING_ROD.
  1. Нажмите Окно (Window) > ENGINE_COMPLETE.ASM в главном меню.
  2. Нажмите Обновить (Regenerate) [image] на главной панели инструментов.
    1. Сборка слегка изменилась, что обусловлено укорочением модели CONNECTING_ROD.PRT.

Обновление сборки


Previous Page 72 of 76 Next
Information

Выполнение проигрывания Механизма (Mechanism)

Поскольку Анализ Механизма (Mechanism Analysis) ранее был выполнен, то можно использовать опцию Проиграть Анализ (Replay Analysis) для 'анимации' механизма в режиме непрерывного воспроизведения. Можно также использовать опцию Общее Взаимопроникновение (Global Interference) для проверки на любое взаимопроникновение между компонентами в процессе воспроизведения.

Задача 5-3. Выполнение проигрывания механизма для просмотра взаимопроникновения, полученного из-за укорочения модели CONNECTING_ROD.

  1. Нажмите Приложения > Механизм (Applications > Mechanism) в главном меню.
    • Нажмите Выполнить Анализ (Run Analysis) [image] на панели инструментов механизма (справа от экрана).
    • Выберите имя RUN_ENGINE и нажмите Выполнить (Run) в диалоговом окне Анализы (Analyses). Затем нажмите Закрыть (Close).
    • Нажмите Проиграть Анализы (Replay Analysis) [image] на панели инструментов механизма (справа от экрана).
    • Выберите Общее Взаимопроникновение (Global Interference) и нажмите Проиграть (Play) [image] в диалоговом окне Анимация (Playbacks). (взаимопроникновение будет вычисляться несколько секунд).
    • Перетяните ползунок Скорость (Speed) на максимум и нажмите Проиграть (Play) [image] в диалоговом окне Анимация (Playbacks).
    • Заметьте, что в процессе движения происходит взаимопроникновение (красная подсветка) внизу поршня.

Взаимопроникновение (Interference) обнаружено

  2. Нажмите Стоп (Stop) [image] , когда закончите просмотр взаимопроникновения, и затем нажмите Закрыть > Закрыть (Close > Close).
  3. Нажмите Переместить Компонент (Drag Component) [image] на панели инструментов механизма (справа от экрана).
  4. Дважды кликните на имя Snaphot1 и нажмите Закрыть (Close).
  5. Нажмите Приложения > Стандартное (Applications > Standard) в главном меню и нажмите Да (Yes) в окне сообщений.
  6. Нажмите Файл > Закрыть Окно (File > Close Window) [image] для возвращения в деталь CONNECTING_ROD.


Previous Page 73 of 76 Next
Задача 5-4. Обзор эффектов в чертеже и модификация модели CONNECTING_ROD путем возвращения длины в ее начальное значение.

Note
ВАЖНО - следующим шагом Вы будете открывать второе окно Pro/ENGINEER. Вы должны изменить размеры и положение окна справа от учебника.

  1. Выберите Навигатор Папок (Folder Browser) [image] и выберите папку ProE_models.
    1. Выберите модель ENGINE_COMPONENTS.DRW из браузера для обзора в окне предпросмотра.
    2. Нажмите Следующий Лист (Next Sheet) [image], затем нажмите Открыть в Pro/E (Open in Pro/E) [image].
    3. Заметьте, что в чертеже открылся сразу Лист 2 (Sheet 2).
  2. Разместите указатель мыши между видами FRONT (фронтальный) и TOP (верхний).
    1. Нажмите CTRL, нажмите и удерживайте среднюю кнопку мыши, и передвиньте мышь к себе для приближения вида.
    2. Заметьте, что чертежные виды и размеры обновлены до новой длины 30.

Обновление чертежа

  3. Выберите размер 30. Дважды кликните на значении 30, введите 33 и нажмите ENTER.
  4. Нажмите Обновить (Regenerate) [image] на главной панели инструментов.
    1. Заметьте, что чертежные виды и размеры обновились.
  5. Нажмите Окно (Window) > CONNECTING_ROD_COMPLETE.PRT для просмотра детали.
    1. Дважды кликните на середину модели для отображения размеров элемента-фичера ВЫТЯГИВАНИЕ 1 (EXTRUDE 1).
    2. Заметьте, что размер элемента-фичера обновлен до предыдущего значения 33.
  6. Нажмите Файл > Закрыть Окно ( File > Close Window) [image] дважды для закрытия обоих окон.


Previous Page 74 of 76 Next
Задача 5-5. (На усмотрение) Перепроверка взаимопроникновения (Interference) на верхнем уровне сборки.
  1. Выберите Навигатор Папок (Folder Browser) [image] и выберите папку ProE_models.
    1. Выберите модель AC-40.ASM из браузера для обзора в окне предпросмотра.
    2. Нажмите Открыть в Pro/E (Open in Pro/E) [image].
  2. Нажмите Переместить Компонент (Drag Component) [image] на главной панели инструментов.
    1. Выберите любую крыло крыльчатки (внутреннего вентилятора) и потяните механизм.
    2. Нажмите среднюю кнопку мыши для завершения перетягивания.
  3. Запустите механизм и наблюдайте любое взаимопроникновение как показано на следующем рисунке:
    • Нажмите Приложения > Механизм (Applications > Mechanism) в главном меню.
    • Нажмите Выполнить Анализ (Run Analysis) [image] на панели инструментов механизма.
    • Выберите имя RUN_ENGINE и нажмите Выполнить (Run). Нажмите Закрыть (Close) в диалоговом окне Анализы (Analyses).
    • Нажмите Проиграть Анализы (Replay Analysis) [image] на панели инструментов механизма.
    • Выберите Общее Взаимопроникновение (Global Interference) и нажмите Проиграть (Play) [image] в диалоговом окне Анимация (Playbacks). (взаимопроникновение будет вычисляться несколько секунд).
    • Перетяните ползунок Скорость (Speed) на максимум и нажмите Проиграть (Play) [image] в диалоговом окне Анимация (Playbacks).
    • Заметьте, что взаимопроникновения не происходит.

Взаимопроникновение (interference) не обнаружено

  4. Нажмите Стоп (Stop) [image], когда закончите просмотр взаимопроникновения, и затем нажмите Закрыть > Закрыть (Close > Close).
  5. Нажмите Приложения > Стандартное (Applications > Standard) в главном меню и нажмите Да (Yes) в окне сообщений.
  6. Нажмите Сохранить (Save) [image] и затем нажмите OK.

Этим завершается пятое упражнение.


Previous Page 75 of 76 Next

ПОЗДРАВЛЕНИЯ !

Теперь Вы завершили Учебник начального курса.

РЕЗЮМЕ

Теперь Вы завершили этот учебник и можете:

  • Описать основы Pro/ENGINEER Wildfire.
  • Управлять интерфейсом Pro/ENGINEER Wildfire.
  • Делать предпросмотр, открытие и ориентацию разработанных моделей.
  • Создавать простые модели деталей.
  • Создавать сборку.
  • Запускать простой механизм.
  • Создавать чертеж с видами сборки и детали.
  • Отображать и управлять размерами на чертежных видах.
  • Модифицировать модель и исследовать обновление сборки и чертежа.
  • Проверять взаимопроникновения в сборке.


Previous Page 76 of 76

Хотите получить лучшее в своем роде обучение Pro/ENGINEER без неудобных и затратных поездок?

Это просто – только свяжитесь с PTC University! PTC University это онлайновый портал, который включает глубину и ширину программ традиционного обучения компании PTC с удобством, гибкостью и экономичностью дистанционного образования.

С помощью PTC University Вы имеете доступ к множеству эффективных форм дистанционного обучения, включая Виртуальные Классы (Virtual Classes), Веб-ориентированный тренинг (Web-based Training), Активы электронных Знаний (e-Knowledge Assets) и Сообщество Практикующих (Communities of Practice).

Или Вы хотите совершенствовать Ваши существующие навыки, или изучать новую технику работы, PTC University даст Вам верную информацию в нужное время с аудиовизуальным сопровождением - всегда с комфортом для Вас.

Изучайте больше в PTC University, который может помочь Вам улучшить разработку Ваших знаний продуктов www.ptc.com/go/learning.


Pro/ENGINEER Wildfire 2.0 для новых пользователей

Введение

Окно этого учебника можно расположить рядом с Pro/ENGINEER Wildfire 2.0.

  • Убедитесь в том, что Pro/ENGINEER Wildfire 2.0 установлен на этом компьютере.
  • Если Pro/ENGINEER сейчас запущен, то нужно выйти из него.

Для начала необходимо подготовить стартовую команду для Pro/ENGINEER и расположить модели Pro/ENGINEER для этого учебника:

  1. Скачать файлы моделей нужно с www.ptc.com/go/handson/models. Сохраните архив на компьютере.
  2. Распакуйте архив на жесткий диск компьютера.
    • Рекомендуется распаковать на диск C:\.
  3. Просмотрите - правильно ли создалась структура папок.
    • Например: C:\users\student\HOW_INTRO-WF2
  4. Убедитесь, что Pro/ENGINEER Wildfire 2.0 установлен на компьютере и перетяните ярлык из меню "Пуск/Программы/PTC/Pro ENGINEER/Pro ENGINEER". Для этого:
    • Правой кнопкой мыши щелкните на ярлыке Pro ENGINEER и выберите Копировать.
    • Правой кнопкой мыши щелкните на рабочем столе и выберите Вставить ярлык.
  5. Правой кнопкой мыши щелкните на полученном ярлыке и выберите Свойства.
    • Введите (или скопируйте отсюда) полный путь до рабочего каталога Intro_HOW.
    • Например: C:\users\student\HOW_INTRO-WF2
  6. Запустите Pro/ENGINEER Wildfire 2.0 используя полученный ярлык.

Использование этого учебника

  • Внимательно прочтите содержание каждой страницы и выполняйте указанные шаги перед тем, как перейти на другую страницу.
  • Можно заметить следующие иконки на всем протяжении учебника:
    • Information Information обеспечивает начало большинства задач.
    • Tip Tips обеспечивает подсказками по всему учебнику.
    • Note Notes обеспечивает дополнительной информацией.
  • Существуют некоторые условности при работе с Pro/ENGINEER Wildfire 2.0:
    • "Укажи и нажми" ("picks and clicks") показаны Жирным.
    • Текст, который нужно вводить с клавиатуры показан Жирным.
    • Иконки и их названия расположены в одной строке текста.
    • Имена моделей показаны заглавными буквами.
    • Кнопки клавиатуры показаны заглавными буквами.

Добро пожаловать

Этот учебник поможет приобрести базовые навыки моделирования деталей, а также созданию сборок и чертежей. Этот учебник разработан для студентов, которые никогда не пользовались Pro/ENGINEER.

Содержание

Нажмите Next для продолжения обучения основам Pro/ENGINEER Wildfire 2.0 или используйте следующие ссылки для навигации по разделам внутри этого учебника:

  • Pro/ENGINEER Wildfire 2.0 Основные понятия
    • Изучение основ Pro/ENGINEER Wildfire 2.0
  • Упражнение 1: Открытие, Ориентирование и Редактирование Моделей
    • Описание основ Pro/ENGINEER Wildfire.
    • Навигация по интерфейсу Pro/ENGINEER Wildfire.
  • У пражнение 2: Создание моделей деталей
    • Просмотр, открытие и ориентация разработанных моделей.
    • Создание моделей простых деталей.
  • У пражнение 3: Создание сборок
    • Создание сборки.
    • Запуск простого механизма.
  • У пражнение 4: Создание чертежа
    • Создание чертежа с видами сборки и детали.
    • Отображение и манипуляция с размерами на чертежных видах.
  • У пражнение 5: Ассоциативность модели
    • Модификация модели и исследование обновления сборки и чертежа.
    • Проверка пересечений в сборке.
Information

Секция основных понятий

Прочитайте пять страниц этой секции основ Pro/E Wildfire 2.0 перед тем как приступить к первому уроку.

Pro/ENGINEER Wildfire 2.0 Основные понятия

В этом учебнике рассматриваются шесть основных понятий Pro/ENGINEER Wildfire 2.0:

  • Твердотельное (Solid) моделирование
  • Элементное (Feature) планирование
  • Параметризация
  • Зависимости Родитель / Потомок
  • Ассоциативность
  • Центральная модель

Твердотельное (Solid) моделирование

Pro/ENGINEER Wildfire 2.0 позволяет простым образом создавать 3D модели, с возможностью показывать детали и сборки реалистичного вида. Основанные на таком свойстве материала, как плотность, эти модели имеют массу, объем, площадь поверхности и другие физические свойства, такие как центр тяжести.

Для примера, рассмотрим образец блока алюминиевого двигателя, показанный ниже. Эта модель была создана в миллиметрах, ниже приводятся ее массовые свойства. Координатная система, обозначенная цифрами 123, показывает центр тяжести модели.

У твердотельного моделирования есть следующие достоинства:

  • При изменении модели (например, увеличении числа охлаждающих ребер), все массовые свойства будут автоматически обновлены.
  • В твердотельных (Solid) моделях всегда можно настроить поля допусков и проверить зазоры/пересечения между компонентами в сборке.

ОБЪЕМ = 3.332e+04 MM^3
ПЛОЩАДЬ ПОВЕРЖНОСТИ= 2.488e+04 MM^2
ПЛОТНОСТЬ = 2.7e-06 KG/MM^3
МАССА = 8.998e-02 KG

ЦЕНТР ТЯЖЕСТИ
X = -0.642 MM
Y = 20.508 MM
Z = 24.194 MM

Твердотельная модель и ее массовые характеристики

Элементное (Feature) планирование

Модели Pro/ENGINEER Wildfire 2.0 конструируются при помощи последовательности элементов-фичеров (features). Каждый элемент-фичер строится на предыдущем элементе-фичере, тем самым последовательно создается модель. Каждый из элементов-фичеров в отдельности может быть простым, но совместно они создают сложные формы деталей и сборок.

На следующем рисунке показан шатун на различных стадиях создания:

  1. Элемент-фичер Выдавливание (Extrude) формирует предельную форму и размер модели.
  2. Дополнительный элемент-фичер Выдавливание (Extrude) создается сверху и снизу модели.
  3. Элемент-фичер Отверстие (Hole) создается сверху и снизу модели.
  4. Элемент-фичер Скругление (Round) создается сверху и снизу модели.

Элементы-фичеры ШАТУНА

Параметричность

Управлять моделями Pro/ENGINEER Wildfire 2.0 можно через значения размеров. Если размер элемента-фичера изменятся, то тело элемента-фичера обновляется. Это изменение автоматически передается по наследству всем остальным элементам-фичерам модели, обновляя всю деталь.

Зависимости Родитель/Потомок

Зависимости Родитель/Потомок обеспечивают мощный способ запечатлеть Вашу "цель разработчика" в модели. Зависимости Родитель/Потомок автоматически созданы между элементами-фичерами в течение процесса моделирования. Во время создания элемента-фичера, существующие элементы, на которые он ссылается - являются родителями для этого нового элемента-фичера. К тому же, при обновлении родительского элемента-фичера, элемент-фичер потомок также будет обновлен.

На следующем рисунке, модель ПОРШНЯ имеет высоту 18.5 с размером до отверстия 8 от верхней поверхности. Размер высоты был изменен до 24 и модель была Обновлена (Regenerate) для того, чтобы обновить эти элементы-фичеры. Обратите внимание, как зависимость Родитель/Потомок между отверстием и телом модели принуждает отверстие передвинуться верх для сохранения размера 8.

Редактирование высоты
ПОРШНЯ

Это поведение (отверстие, ссылающееся на верхнюю поверхность) - пример осуществления цели разработчика, которая задана в модели. В другом случае, отверстие может ссылаться на нижнюю поверхность, следуя уже по другому пути при изменении высоты модели.

Ассоциативность и Центральная модель

Если модель детали Pro/ENGINEER Wildfire 2.0 была изменена, любые сборки или чертежи, которые ссылаются на эту модель, будут автоматически обновлены. Такое поведение называется Ассоциативностью (Associativity) и также работает в обратном порядке - если размер модели в чертеже обновился, то модель детали или сборки, используемая для этого чертежа, также будет обновлена.

Модель детали это центральный источник информации разработчика. Однажды созданная модель может быть:

  • Помещена в сборку - в зависимости от способа размещения компонентов, они могут быть закреплены неподвижно или могут быть приведены в движение как механизм.
  • Использована для создания чертежа - двухмерные виды модели могут быть быстро размещены на листе чертежа и размеры могут быть автоматически показаны.

Ассоциативность модели

Интерфейс Pro/ENGINEEER Wildfire 2.0

Вот следующие основные компоненты интерфейса:

  • Графическое Окно (Graphics Window) - большая серая область для отображения модели.
  • Навигатор (Navigator) - выдвигаемые панели слева экрана.
    • Браузер (Browser) - многофункциональный веб-браузер, отображающий список моделей и маленькое окно предварительного просмотра по центру экрана.
    • Дерево Модели (Model Tree) - список элементов-фичеров детали или компонентов в сборке; слева от экрана.
    • Дерево Папок (Folder Browser) (не показано) - отображается слева от экрана на месте дерева модели и показывает дерево папок на компьютере или в локальной сети. Можно посмотреть папки и увидеть их содержание в Браузере.
  • Главное Меню (Main Menu) - расположено сверху экрана; это меню с выпадающими командами, которое содержит обычные опции, такие как Файл (File), Редактировать (Edit), Вставить (Insert), Инструменты (Tools) и Справка (Help).
  • Главная Панель Инструментов (Main Toolbar) - панель с иконками, расположенная сверху экрана.
  • Панель Элементов-фичеров (Feature Toolbar) - панель с иконками, расположенная в правой части экрана.
  • Панель Управления (Dashboard) (не показана) - диалоговая панель, располагающаяся снизу экрана во время создания элементов-фичеров.

Урок 1: Открытие, ориентирование и редактирование моделей.

Обзор - в этом уроке изучаются три основных навыка, которые необходимы при моделировании в Pro/ENGINEER Wildfire 2.0

  • Предварительный просмотр (Preview) и открытие разработанных моделей - Вы будете использовать Навигатор (Navigator) и браузер (Browser) для обзора папок, предварительного просмотра и открытия моделей.
  • Ориентирование разработанных моделей - после открытия существующей модели, Вы будете использовать сочетание кнопок клавиатуры и мыши для Вращения (Spin), Смещения (Pan) и Масштабирования (Zoom) моделей.
  • Редактирование существующих разработанных моделей - после изучения основ ориентирования модели, Вы будете использовать команды редактирования для модификации существующих моделей.
Information

Рабочая папка (Working Directory)

Рабочая папка (Working Directory) является папкой, из которой производится открытие и в которую производится сохранение моделей.

Задача 1-1. Открытие модели ENGINE_BLOCK.PRT, используя Навигатор (Navigator).
  1. Запустите Pro/ENGINEER Wildfire 2.0, если необходимо. По умолчанию в Браузере отображается веб-страница с содержимым из папки запуска Pro/ENGINEER Wildfire 2.0.
  2. В Навигаторе Папок (Folder Browser) [image] (слева экрана), выберите папку HOW_INTRO-WF2 и раскройте ее, нажав '+'.
  3. Выберите папку ProE_models для обзора содержимого в браузере.
  4. Нажмите правой кнопкой мыши на папке ProE_models и выберите команду Задать Рабочую Папку (Set Working Directory).
  5. Выберите ENGINE_BLOCK.PRT из браузера.
    1. Обратите внимание на предпросмотр модели, появившийся вверху браузера.
  6. Нажмите кнопку Открыть Файл в Pro/E (Open File in Pro/E) [image] из браузера (справа от окна предпросмотра).

ENGINE_BLOCK.PRT
Information

Команды ориентации модели

Вращение (Spin): Вращение модели на экране.
Смещение (Pan): Смещение модели на экране.
Масштабирование (Zoom): Приближает или отдаляет модель от Вас.
Стандартная ориентация (Standard Orientation): Ориентирование, которое служит для возврата в начальное положение обзора модели.

Задача 1-2. Практика использования Вращения (Spin), Смещения (Pan) и Масштабирования (Zoom) модели ENGINE_BLOCK.

  1. Для вращения модели нажмите и удерживайте среднюю кнопку мыши и двигайте мышь в различных направлениях.
  2. Нажмите кнопку Список Сохраненных Видов (Saved View List) [image] на главной панели инструментов (сверху экрана) и выберите Стандартаную ориентацию (Standard Orientation).
  3. Приближение и отдаление модели :
    • Расположите указатель мыши на желаемую область модели.
    • Нажмите клавишу CTRL, нажмите и удерживайте среднюю кнопку мыши и, передвигая мышь на себя, приблизьте модель к себе.
    • Нажмите клавишу CTRL, нажмите и удерживайте среднюю кнопку мыши и, передвигая мышь от себя, отдалите модель от себя.

Note
Начальное положение указателя мыши определяет область масштабирования.

  4. Если мышь имеет колесико, то попробуйте с помощью него масштабировать модель:
    1. Покрутите колесико на себя для увеличения (без использования клавиши CTRL).
    2. Покрутите колесико от себя для уменьшения.
  5. Нажмите кнопку Список Сохраненных Видов (Saved View List) [image] на главной панели инструментов и выберите Стандартную ориентацию (Standard Orientation).
  6. Смещение модели на экране:
    1. Нажмите клавишу SHIFT, нажмите и удерживайте среднюю кнопку мыши и двигайте мышь в различных направлениях.
  7. Нажмите кнопку Список Сохраненных Видов (Saved View List) [image] на главной панели инструментов и выберите Стандартную ориентацию (Standard Orientation).
Tip

Можно использовать сочетание клавиш CTRL + D как комбинацию для возврата к Стандартной ориентации (Standard Orientation).

Information

Выбор при помощи мыши

Двигайте мышку по элементам-фичерам для их подсветки. Нажмите левую кнопку мыши для того, чтобы сделать выбор. Голубой цвет (светло синий) подсветки показывает предварительный выбор элемента. Красный цвет подсветки показывает выбранный элемент. Поскольку элемент-фичер был выбран, то его кромки или поверхности останутся подсвеченными.

Задача 1-3. Выбор крепежного фланца.

  1. Подсветите и выберите элемент-фичер как показано на следующем рисунке:
    • Поместите указатель мыши над элементом-фичером ВЫТЯГИВАНИЕ_2 (EXTRUDE_2) так, чтобы подсветка стала голубого цвета.
    • Выберите элемент-фичер ВЫТЯГИВАНИЕ_2 (EXTRUDE_2) нажав на него левой кнопкой мыши (кликните) так, чтобы он подсветился красным цветом.

Tip
Увеличьте модель, для упрощения выбора.

Подсветка элемента-фичера (Feature)

  2. Нажмите левой кнопкой мыши (кликните) на окружающий модель фон, для снятия выбора.
  3. Подсветите и выберите ВЫТЯГИВАНИЕ_2 (EXTRUDE_2) снова.
    1. Оставьте этот элемент-фичер выбранным и продолжите упражнение.
Information

Команда Править Определения (Edit Definition) и Указатели (Handles)

Команда Править Определение (Edit Definition) открывает инструментальную панель элементом-фичером, благодаря которой можно произвести любые необходимые корректировки этого элемента-фичера.

Работа по принципу 'нажмите правой* и подождите' используется для доступа к всплывающему меню, тогда как быстрое 'нажмите правой* и получите' будет подсвечивать следующий элемент-фичер под указателем мыши. (*Нажмите правой кнопкой мыши)

Указатели (handles) это маленькие белые квадратики, расположенные на желтой заготовке элемента-фичера.

Задача 1-4. Правка определения крепежного фланца ВЫТЯГИВАНИЕ_2 (EXTRUDE_2) для его утолщения.

  1. После выбора элемента-фичера ВЫТЯГИВАНИЕ_2 (EXTRUDE_2) нажмите правой и подождите, выбрав затем пункт Править Определение (Edit Definition).
    1. Обратите внимание, что в процессе переопределения не показывается, как создавался этот элемент-фичер.
  2. Потяните указатель (handle) глубины на модели (белый квадратик на желтой заготовке) от 2 до 5, как показано на следующем рисунке.
    1. Заметьте, что величина глубины была обновлена на инструментальной панели (внизу экрана).

Переопределение элемента-фичера

  3. Нажмите кнопку Применить (Complete Feature) [image] справа инструментальной панели (снизу экрана).
    1. Модель с множеством элементов-фичеров, располагающихся после этого вытягивания, через некоторое время будет обновлена.
    2. Заметьте, что эта модификация коснулась также противоположной стороны модели, что обусловлено наличием зависимостей Родитель/Потомок.
Information

Редактирование размеров элемента-фичера

Команда Править (Edit) отображает размеры элемента-фичера и позволяет вводить новые значения. После этого необходимо Обновить (Regenerate) модель для ее обновления.

Задача 1-5. Редактирование размеров крепления карбюратора и отмена изменений.

  1. Подсветите и выберите элемент-фичер вытягивания как показано на следующем рисунке.

Выбор элемента-фичера

  2. Нажмите правой и подождите, затем выберите Правка (Edit). Появятся сечение и размеры элемента-фичера.
  3. Дважды кликните на размере 14.5, введите 11.5 и нажмите клавишу ENTER.
  4. Нажмите кнопку Обновить (Regenerate) [image] на главной панели инструментов (сверху экрана) для обновления модели.

Модель обновилась

  5. Нажмите кнопку Отменить (Undo) [image] на главной панели инструментов (сверху экрана) для отмены последней редакции.

Tip
Можно нажать CTRL + Z для вызова команды Отменить (Undo).

Information

Создание скругления

Скругления (Rounds) позволяют добавлять и убирать материал модели, прилагая радиус к кромке. Можно просто выбрать кромку, назначить радиус и получить элемент-фичер.

Задача 1-6. Создание скругления на креплении карбюратора для сглаживания острой кромки.

  1. Нажмите кнопку Скругления (Round Tool) [image] на панели элементов-фичеров (справа на экране).
  2. Выберите кромку, как показано на следующем рисунке.
    1. Заметьте, что скругление автоматически следует по цепочке касательно расположенных кромок.

Выбор Кромки (Edge)

  3. Потяните за любой указатель (handle) радиуса (белый квадратик на желтой заготовке) до значения 1.
  4. Нажмите Применить (Complete Feature) [image] на инструментальной панели (снизу экрана).
    1. Заметьте, что элемент-фичер Скругление (Round) располагается в самом низу дерева модели (слева экрана)

Скругление (Round) создано

Information

Отменить / Вернуть (Undo / Redo)

Можно использовать команды Отменить (Undo) и Вернуть (Redo) для исправления неудачных действий.

Задача 1-7. Удаление скругления и Отмена (Undo) удаления.

  1. Произведите выбор скругления (подсветка красным цветом), нажмите правой и подождите, выберите Удалить (Delete), затем нажмите OK.
  2. Нажмите кнопку Undo [image] на главной панели инструментов для возвращения элемента-фичера в модель.
  3. Нажмите кнопку Save [image] на главной панели инструментов и нажмите OK.
  4. Нажмите кнопку Файл > Закрыть Окно (File > Close Window) [image].

Note
Модели остаются в памяти сессии до тех пор, пока не будет выполнена команда Удалить ... из сессии (Erased).

Этим завершается первое упражнение.

Упражнение 2: Создание моделей деталей.

Обзор - В этом упражнении будет изучаться моделирование простых деталей для получения навыков путем создания трех моделей:

  • PISTON_PIN.PRT
  • PISTON.PRT
  • CONNECTING_ROD.PRT

ПОРШНЕВОЙ ПАЛЕЦ (PISTON_PIN) и ПОРШЕНЬ (PISTON)

ШАТУН (CONNECTING_ROD)

Information

Создание моделей деталей

Новые модели Деталей (Part) создаются на основе базового шаблона, который по умолчанию содержит базовые плоскости и координатную систему.

Базовые Плоскости по умолчанию (Default datum planes) обеспечивают 3 перпендикулярные плоскости в трехмерном пространстве, которые могут быть использованы как первоначальные привязки, когда создаются элементы-фичеры в модели.

Все базовые шаблоны в данном практикуме предполагают использование миллиметров.

Задача 2-1. Создание модели ПОРШНЕВОГО ПАЛЬЦА (PISTON_PIN) используя базовый шаблон.

  1. Нажмите кнопку Новый (New) [image] на главной панели инструментов и выберите Деталь (Part) в качестве Типа (Type). Напишите PISTON_PIN как Имя (Name) и нажмите ENTER.

Новая Модель Детали (Part)

  2. Нажмите кнопку Базовые оси (Datum Axes) [image], Базовые точки (Datum Points) [image] и Системы координат (Coordinate Systems) [image] на главной панели инструментов (сверху экрана) для выключения их отображения.
Information

Создание эскизов (Sketches)

Эскиз (Sketch) это основная двухмерная (3D) фигура, используемая для создания элемента-фичера, и эта фигура создается на плоскости.

Однажды созданные, эскизы могут быть простым образом использованы для создания трехмерных (3D) элементов-фичеров.

Задача 2-2. Создание эскиза круга для использования его в создании основного тела модели.

  1. Нажмите кнопку Рисование (Sketch Tool) [image] на панели элементов-фичеров (справа на экране).
  2. Выберите базовую плоскость FRONT на модели и нажмите кнопку Эскиз (Sketch) в диалоговом окне Эскиз (Sketch).
  3. Нажмите кнопку Закрыть (Close) в диалоговом окне Привязки (References).
  4. Нажмите кнопку Базовые плоскости (Datum Planes) [image] на главной панели инструментов (сверху экрана) для отключения их отображения.
  5. Нарисуйте круг, как показано на следующем рисунке:
    • Нажмите кнопку Окружность (Circle) [image] на панели инструментов эскиза (справа от экрана).
    • Расположите указатель мыши в месте пересечения базовых плоскостей.
    • Кликните (левой кнопкой мыши) и образуется точка размещения центра окружности, передвиньте мышку в сторону, затем кликните снова.
    • Заметьте, что размер диаметра создался автоматически.
    • Нажмите кнопку Выбрать объекты (Select Items) [image] на панели инструментов эскиза (справа от экрана) для перехода в режим выбора объектов.
    • Дважды кликните на значении диаметра, введите 5 и нажмите ENTER.

Создание эскиза

  6. Нажмите кнопку Продолжить (Complete Sketch) [image] на панели инструментов эскиза (справа от экрана).
  7. Нажмите кнопку Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
  8. Нажмите кнопку Базовые плоскости (Datum Planes) [image] на главной панели инструментов для включения их отображения.
Information

Использование инструмента Выдавливание (Extrude Tool)

Инструмент Выдавливание (Extrude Tool) позволяет брать эскиз и линейно выдавливать его для создания элемента-фичера.

Вы можете добавить материал вытягиванием (protrusion) или удалить материал вырезом (cut) в процессе работы инструмента Выдавливание (Extrude).

Задача 2-3. Создание вытягивания, используя предыдущий эскиз.

  1. Выберите эскиз (подсветка красным цветом), создайте элемент-фичер Вытягивание (Extrude) как показано на следующем рисунке:
    • Нажмите на кнопку инструмент Выдавливание (Extrude Tool) [image] на панели элементов-фичеров (справа на экране).
    • Потяните указатель (handle) (белый квадратик на желтой заготовке) до 4.
    • Нажмите на черную стрелку Опции Глубины (Depth Options Flyout) [image] на инструментальной панели (снизу экрана) и выберите ...в обе стороны... (Both Sides) [image].
    • Ведите 20 на инструментальной панели для задания глубины и нажмите ENTER.
    • Нажмите кнопку Вписать...в окно (Refit) [image] на главной панели инструментов (сверху экрана).
    • Нажмите кнопку Применить (Complete Feature) [image] на инструментальной панели (снизу экрана).

Элемент-фичер Выдавливание создан

  2. Нажмите кнопку Сохранить (Save) [image] на главной панели инструментов и нажмите OK.
  3. Выберите команду Файл > Закрыть Окно (File > Close Window) [image].
Information

Создание ПОРШНЯ (PISTON)

ПОРШЕНЬ (PISTON) также начинает создаваться с использованием эскиза окружности, но он будет размещен на другой плоскости.

Задача 2-4. Создание PISTON.PRT и создание первого эскиза.

  1. Нажмите Новый (New) [image] на главной панели инструментов и выберите Деталь (Part) в качестве Типа (Type).
  2. Введите PISTON в как Имя (Name) и нажмите ENTER. Новая модель детали создалась из шаблона по умолчанию.
  3. Нажмите Рисование (Sketch Tool) [image] на панели элементов-фичеров (справа на экране).
  4. Выберите базовую плоскость TOP на модели, и нажмите Эскиз (Sketch) в диалоговом окне Эскиз (Sketch).
  5. Нарисуйте окружность (circle) как показано на следующем рисунке:
    1. Нажмите Закрыть (Close) в диалоговом окне Привязки (References).
    2. Нажмите Базовые плоскости (Datum Planes) [image] на главной панели инструментов (сверху экрана) для выключения их отображения.
    3. Нажмите Окружность (Circle) [image] на панели инструментов эскиза (справа от экрана).
    4. Кликните (левой кнопкой мыши) и образуется точка размещения центра окружности, передвиньте мышку в сторону, затем кликните снова.
    5. Нажмите Выбрать объекты (Select Items) [image] на панели инструментов эскиза (справа от экрана) для перехода в режим выбора объектов.
    6. Дважды кликните на значении диаметра, введите 21 и нажмите ENTER.

Создание эскиза

  6. Нажмите кнопку Продолжить (Complete Sketch) [image] на панели инструментов эскиза (справа от экрана).
  7. Нажмите кнопку Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
  8. Нажмите кнопку Базовые плоскости (Datum Planes) [image] на главной панели инструментов для включения их отображения.
Information

Изменение Направления Выдавливания (Depth Direction)

Можно изменить направление создания элемента-фичера относительно эскизной плоскости, используя кнопку Направление Выдавливания (Change Depth Direction).

Задача 2-5. Использование предыдущего эскиза для создания первого элемента-фичера Вытягивание (Extrude).

  1. Выберите эскиз, создайте элемент-фичер Вытягивание (Extrude) как показано на следующем рисунке:
    • Нажмите на инструмент Выдавливание (Extrude Tool) [image] на панели элементов-фичеров (справа на экране).
    • Дважды кликните на значении глубины, введите 18.5 и нажмите ENTER.
    • Нажмите Направление Выдавливания (Change Depth Direction) [image] на инструментальной панели (снизу экрана) для изменения направления создания элемента-фичера в обратную сторону.
    • Нажмите Продолжить (Complete Sketch) [image] на панели инструментов эскиза.
Note
Шаг сдвига указателя (handle) на данный момент установлен в 1mm.

Элемент-фичер Выдавливание создан

Information

Создание Группы (Group) элементов-фичеров

Следующий твердотельный элемент-фичер создан как Вытянутый Вырез (Extruded Cut) для создания пустоты в ПОРШНЕ (PISTON). Для того чтобы осуществить желаемую размерную схему при создании отверстия, этот эскиз будет размещен на базовой плоскости, построенной на расстоянии от верхней поверхности модели.

Для этого нужно нажать на инструмент Выдавливания (Extrude tool) и Приостановить (Pause) его. Перед этим элементом-фичером будет создана базовая плоскость и эскиз. Когда инструмент Выдавливания (Extrude tool) будет Возобновлен (Resumed) и завершен, система автоматически создаст Группу (Group) в дереве модели. Группа позволяет редактировать несколько элементов-фичеров и манипулировать ими сразу.

Задача 2-6. Запуск инструмента Выдавливания (Extrude tool) и создание базовой плоскости.

  1. Нажмите на инструмент Выдавливания (Extrude tool) [image] на панели элементов-фичеров (справа на экране).
  2. Нажмите Приостановить... (Pause Feature) [image] на инструментальной панели (снизу экрана).
    1. Заметьте, что инструментальная панель становится неактивной (серой), показывая остановку работы.
  3. Нажмите на инструмент Базовая Плоскость (Datum Plane Tool) [image] на панели элементов-фичеров (справа на экране).
  4. Выберите базовую плоскость TOP на модели и произведите смещение указателя (handle) вниз на 2.
  5. Нажмите OK в диалоговом окне Базовая Плоскость (Datum Plane).

Базовая плоскость создана

Information

Использование Осевых (Centerlines) в Эскизе (Sketch)

Осевые (Centerlines) помогают добиться симметрии в эскизе. Например, необходимо расположить прямоугольник симметрично, относительно вертикальных и горизонтальных привязок. Осевые отображаются желтой штрихпунктирной линией.

Задача 2-7. Эскиз на предыдущей базовой плоскости. Отрисовка симметричного прямоугольника.
  1. При выбранной базовой плоскости необходимо нажать Рисование (Sketch Tool) [image] на панели элементов-фичеров.
    1. Заметьте, что базовая плоскость DTM1 автоматически выбрана как Плоскость Эскиза (Sketching Plane).
    2. Нажмите Эскиз (Sketch) в диалоговом окне Эскиз (Sketch).
    3. Нажмите Закрыть (Close) в диалоговом окне Привязки (References).
    4. Нажмите Базовые плоскости (Datum Planes) [image] на главной панели инструментов (сверху экрана) для выключения их отображения.
    5. Нажмите Нет Скрытых (No Hidden) [image] а главной панели инструментов.
    6. Обратите внимание на две желтовато-коричневые штриховые линии - это и есть привязки эскиза. Нарисованная геометрия будет привязываться к этим привязкам.
  2. Нарисуйте осевые и прямоугольник как показано на следующем рисунке:
    • Нажмите черную стрелку на кнопке Типы линий (Line Types Flyout) [image] на панели инструментов эскиза (справа от экрана) и выберите Осевая (Centerline) [image].
    • Укажите два месторасположения на вертикальной привязке эскиза для отрисовки вертикальной осевой линии.
    • Нарисуйте другую осевую линию на горизонтальной привязке эскиза, как показано на рисунке слева.
    • Нажмите Прямоугольник (Rectangle) [image] на панели инструментов эскиза (справа от экрана).
    • Нажмите и получите точку месторасположения верхнего левого угла прямоугольника.
    • Позволяя прямоугольнику привязаться симметрично, Нажмите и получите точку месторасположения нижнего правого угла прямоугольника.

Рисование Осевых и прямоугольника

Note
Всегда используйте метод 'нажмите и получите', когда рисуете геометрию, так как в противном случае задержка нажатой левой кнопки мыши может привести к смещению геометрии.

Information

Рисование Дуг (Arcs)

Инструмент Дуга (Arc) может создавать дуги как по трем точкам, так и касательными (тангенциальными) к объектам. В этой задаче будет создаваться Касательную Дугу (Tangent Arc).

Задача 2-8. Продолжение эскизирования для создания овальной формы. Эскизирование касательных дуг, используя прямоугольник как ориентир.

  1. Нажмите Дуга (Arc) [image] на панели инструментов эскиза (справа от экрана).
    • Нажмите на верхнюю правую вершину прямоугольника и получите начало дуги.
    • Сдвиньте указатель вправо от зеленого символа квадранта для продолжения дуги.
    • Нажмите на нижнюю правую вершину прямоугольника для завершения дуги.
    • При помощи команды Дуга (Arc) [image] нарисуйте похожую дугу слева прямоугольника (двигая указатель уже влево от зеленого символа квадранта).

Рисование касательных дуг

Note
Всегда используйте метод 'нажмите и получите', когда рисуете геометрию, так как в противном случае задержка нажатой левой кнопки мыши может привести к смещению геометрии.

  2. Нажмите среднюю кнопку мыши для остановки эскизирования и перехода в режим выбора объектов.
    1. Заметьте, что кнопка Выбрать Объекты (Select Items) [image] нажалась на панели инструментов эскиза.
    2. Нажмите клавишу CTRL и выберите две вертикальные линии прямоугольника.
    3. Нажмите правой и подождите , затем выберите команду Удалить (Delete).
Information

Создание Размеров (Dimensions)

Много различных типов размеров можно создать инструментом Размер (Dimension). Для создания размера нужно выбрать элементы для образмеривания и нажать среднюю кнопку мыши для получения размера.

Задача 2-9. Завершите построение овальной формы образмериванием.

  1. Нажмите Размер (Dimension) [image] на панели инструментов эскиза (справа от экрана).
    • Выберите каждую из дуг, расположите указатель над эскизом, и нажмите среднюю кнопку мыши для размещения размера.
    • Выберите Гориз (Horiz) во всплывающем диалоговом окне Ориентация размера (Dim Orientation) и нажмите Принять (Accept).
    • После того как кнопка Размер (Dimension) [image] станет нажатой выберите верхнюю и нижнюю линии.
    • Расположите указатель справа от эскиза и нажмите среднюю кнопку мыши для размещения размера.
    • Нажмите среднюю кнопку мыши для остановки эскизирования и перехода в режим выбора объектов. Заметьте, что кнопка Выбрать Объекты (Select Items) [image] нажата.
    • Дважды кликните на горизонтальном размере, введите 18 и нажмите ENTER.
    • Дважды кликните на вертикальном размере, введите 12.5 и нажмите ENTER.

Создание размеров

  2. Нажмите Продолжить (Complete Sketch) [image] на панели инструментов эскиза.
  3. Нажмите кнопку Список сохраненных видов (Saved View List) [image] на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
  4. Нажмите кнопку Базовые плоскости (Datum Planes) [image] на главной панели инструментов для включения их отображения.
  5. Нажмите Закраска (Shading) [image] на главной панели инструментов.
Information

Получение Группы (Group) элементов-фичеров

Так как теперь созданы базовая плоскость и эскиз, можно нажать Возобновить (Resume) и завершить тем самым элемент-фичер Вытягивание (Extrude). Созданное отверстие сделает пустотелым ПОРШЕНЬ (PISTON).

Задача 2-10. Получение Вытянутого Выреза (cut) с использованием предыдущего чертежа.

  1. При выбранном эскизе завершите элемент-фичер Вытягивание (Extrude) как показано на следующем рисунке:
    • Нажмите Возобновить (Resume Feature) [image] на инструментальной панели.
    • Нажмите желтую стрелку направления на модели для изменения направления в обратную сторону.
    • Нажмите на черную стрелку Опции Глубины (Depth Options Flyout) [image] на инструментальной панели и выберите Через все (Through All) [image].
    • Нажмите Удаление материала (Remove Material) [image] на инструментальной панели и затем нажмите Применить (Complete Feature) [image].
    • Нажмите и удержите среднюю кнопку мыши для вращения модели и посмотрите на отверстие с другой стороны.
Tip
Много операций с элементами-фичерами можно сделать, нажимая правую кнопку мыши на указателях (handles) или нажимая на модели, а также используя иконки на инструментальной панели.

Вытянутый Вырез (Cut) создан

Information

Автоматические Группы (Groups)

Базовая плоскость и эскиз автоматически группируются с элементом-фичером Вытягивание (Extrude). Эти дополнительные элементы автоматически делаются Скрытыми (Hidden), чтобы не вызывать беспорядка на экране. Скрытые элементы в дереве модели как бы прикрыты "серой пеленой".

Задача 2-11. Исследование созданной группы в дереве модели.

  1. Расположение группы ВЫТЯГИВАНИЕ_2 (EXTRUDE_2) в дереве модели.
    1. Заметьте, что элемент-фичер Вытянутый Вырез (Extruded Cut) был автоматически сгруппирован с базовой плоскостью и эскизом, используемым для определения.

Дерево модели

Information

Создание линейных Отверстий (Holes)

Отверстия (Holes) удаляют материал с модели и имеют по умолчанию цилиндрическую форму.

Линейные отверстия требуют задать Первичную (Primary) и Вторичные (Secondary) привязки. Первичная привязка - это плоскость расположения отверстия; вторичные привязки - это привязки для расположения размеров.

Задача 2-12. Начало создания отверстия в центре ПОРШНЯ (PISTON).

  1. Нажмите Список сохраненных видов (Saved View List) на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
  2. Нажмите Отверстие (Hole Tool) на панели элементов-фичеров и выберите базовую плоскость FRONT на модели.
    1. Нажмите правой и подождите, затем выберите Коллектор вторичных ссылок (Secondary References).
    2. Нажмите клавишу CTRL и выберите базовые плоскости TOP и RIGHT на модели для расположения размеров до отверстия.

Note

Заметьте, что нужно нажать и удерживать клавишу CTRL для выбора нескольких привязок.

  3. Продолжение создания отверстия - как показано на следующем рисунке:
    • Нажмите Список сохраненных видов (Saved View List) на главной панели инструментов и выберите FRONT.
    • Перетяните указатель (handle) расположения отверстия (в центре отверстия) на позицию, приблизительно показанную на рисунке слева.
    • Выберите закладку Размещение (Placement) на инструментальной панели, измените значения смещения
      от базовой плоскости TOP на 8 и нажмите ENTER.
    • Измените тип размера для базовой плоскости RIGHT со Смещать (Offset) на Выровнять (Align).

Позиционирование Отверстия (Hole)

Задача 2-13. Завершение создания отверстия в центре ПОРШНЯ (PISTON).

  1. Завершите создание отверстия как показано на следующем рисунке:
    • Нажмите Список сохраненных видов (Saved View List) на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
    • Нажмите закладку Форма (Shape) на инструментальной панели.
    • Переключите опцию глубины с Глубины (Blind) на Насквозь (Through All).
    • Переключите опцию глубины для Стороны 2 (Side 2) с Нет (None) на Насквозь (Through All).
    • Введите 5 как диаметр на инструментальной панели и нажмите ENTER.
    • нажмите Продолжить (Complete Feature) .

Отверстие (Hole) создано

Tip
Можно нажать среднюю кнопку мыши для выполнения команды Продолжить (Complete Feature) .

Information

Назначение Цвета (Color) на модель

Можно использовать диалоговое окно Цвет и Образ (Color and Appearance) для создания и назначения цветов для моделей. В этом случае базовая палитра цветов должна быть предварительно загружена.

Задача 2-14. Назначение вида цвета на модель.

  1. Нажмите Базовые плоскости (Datum Planes) на главной панели инструментов для выключения их отображения.
  2. Нажмите Вид > Цвет и Образ (View > Color and Appearance) в главном меню.
    1. Выберите вид цвета Blue_Dark (третья сфера в верхней строке) и нажмите Применить (Apply).
    2. Нажмите Закрыть (Close) в диалоговом окне Редактор Образа (Appearance Editor).

Завершения ПОРШНЯ (PISTON)

  3. Нажмите Сохранить (Save) на главной панели инструментов и нажмите OK.
  4. Нажмите Файл > Закрыть Окно (File > Close Window) .
Information

Создание Шатуна (CONNECTING ROD)

Мы будем создавать тело Шатуна (CONNECTING_ROD), используя эскиз овальной формы и вытягивание.

Задача 2-15. Создание файла CONNECTING_ROD и начало эскизирования.

  1. Нажмите Базовые плоскости (Datum Planes) на главной панели инструментов для включения их отображения.
  2. Нажмите Новый (New) на главной панели инструментов и выберите Деталь (Part) в качестве Типа (Type).
    1. Введите CONNECTING_ROD в качестве Имени (Name) и нажмите ENTER
  3. Нажмите Рисование (Sketch Tool) на панели элементов-фичеров.
    1. Выберите базовую плоскость FRONT на модели и нажмите Эскиз (Sketch) в диалоговом окне Эскиз (Sketch).
    2. Нажмите Закрыть (Close) в диалоговом окне Привязки (References).
    3. Нажмите Базовые плоскости (Datum Planes) на главной панели инструментов для выключения их отображения.
  4. Начните построение овала с рисования двух кругов как показано на следующем рисунке:
    • Нажмите Осевая (Centerline) на панели инструментов эскиза. Укажите два месторасположения на вертикальной привязке эскиза для отрисовки вертикальной осевой линии.
    • Нажмите Окружность (Circle) на панели инструментов эскиза. Кликните на горизонтальной привязке для размещения центра левой окружности, затем завершите построение окружности.
    • Кликните на горизонтальной привязке для размещения центра правой окружности, затем смещайте мышь от центра окружности до тех пор, пока радиус этой окружности не привяжется к радиусу первой окружности, затем кликните снова для завершения построения окружности.
    • Нажмите Закрепления (Constraints) на панели инструментов эскиза.
    • Нажмите Симметричность (Symmetric) и выберите центр каждой окружности и потом осевую линию.
    • Нажмите Закрыть (Close) в диалоговом окне Закрепления (Constraints).

Рисование окружностей (Circles)

Information

Касательные линии (Tangent Lines) и Динамическая Обрезка (Dynamic Trim)

Касательная Линия к двум объектам (2-Tangent Line) позволяет проще нарисовать линии, касательные к двум элементам.

Инструмент Динамическая Обрезка (Dynamic Trim) позволяет удалять ненужные части эскизных элементов. В этом случае кривая (curve), рисуется от руки и протягивается через эскиз, и любые элементы, пересекающиеся с ней, будут удалены.

Задача 2-16. Продолжение рисования овала для модели CONNECTING_ROD.

  1. Продолжите рисование как показано на следующем рисунке:
    • Нажмите черную стрелку на кнопке Типы линий (Line Types Flyout) на панели инструментов эскиза и выберите Касательную Линию (2-Tangent Line) .
    • Позволяя указателю привязываться к окружностям, нарисуйте две горизонтальные линии, как показано на рисунке.

Рисование линий

  2. Нажмите Динамическая Обрезка (Dynamic Trim) на панели инструментов эскиза.
    • Разместите указатель внутри одной из окружностей.
    • Нажмите и задержите левую кнопку мыши, затем протяните кривую линию через внутренние дуги для их удаления (любые элементы, пересеченные этой кривой будут удалены).

Обрезка завершена
Tip
Нажимайте Отменить (Undo) и используйте Динамическую Обрезку (Dynamic Trim) снова, если необходимо.

Задача 2-17. Завершение рисования и создание симметричного Вытягивания (Extrude).

  1. Образмерьте эскиз как показано на следующем рисунке:
    • Нажмите Размер (Dimension) на панели инструментов эскиза.
    • Выберите центр каждой дуги и нажмите среднюю кнопку мыши над эскизом для размещения горизонтального размера.
    • Дважды кликните на левую дугу и затем нажмите левую кнопку мыши слева от эскиза для размещения диаметрального размера.
    • Нажмите среднюю кнопку мыши для завершения рисования и перехода в режим выбора объектов.
    • Дважды кликните на размере диаметра, введите 8.5 и нажмите ENTER.
    • Дважды кликните на размере длины, введите 33 и нажмите ENTER.

Создание и модификация размеров (Dimensions)

  2. Нажмите Продолжить (Complete Sketch) на панели инструментов эскиза.
  3. Нажмите кнопку Список сохраненных видов (Saved View List) на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
  4. Нажмите кнопку Базовые плоскости (Datum Planes) на главной панели инструментов для включения их отображения.
  5. При выбранном эскизе создайте элемент-фичер Вытягивание (Extrude) как показано на следующем рисунке:
    • Нажмите на инструмент Выдавливание (Extrude Tool) на панели элементов-фичеров.
    • Нажмите на черную стрелку Опции Глубины (Depth Options Flyout) на инструментальной панели и выберите В Обе Стороны (Both Sides) .
    • Потяните указатель (handle) глубины до 3.
    • Нажмите Применить (Complete Feature) на инструментальной панели.

Вытягивание завершено

Information

Копирование существующей геометрии

Можно использовать инструмент Объект по Кромке (Entity from Edge) для копирования существующей геометрии. Созданные элементы будут 'приклеены' к существующей геометрии без необходимости образмеривания.

Задача 2-18. Начало создания второго чертежа путем копирования существующей геометрии.

  1. Нажмите Рисование (Sketch Tool) на панели элементов-фичеров.
  2. Нажмите Прежняя (Use Previous) и нажмите Эскиз (Sketch) в диалоговом окне Эскиз (Sketch).
  3. Нарисуйте как показано на следующем рисунке:
    • Нажмите Закрыть (Close) в диалоговом окне Привязки (References).
    • Нажмите Базовые плоскости (Datum Planes) на главной панели инструментов для выключения их отображения.
    • Нажмите Нет Скрытых (No Hidden) на главной панели инструментов.
    • Нажмите Объект по Кромке (Entity from Edge) на панели инструментов эскиза.
    • Выберите дуги и два прямых участка как показано на следующем рисунке.
    • Нажмите Закрыть (Close) в диалоговом окне Тип (Type).

Создание элементов по Кромкам

Задача 2-19. Продолжение рисования эскиза и обрезка.
  1. Нажмите Линия (Line) на кнопке Типы линий (Line Types Flyout) панели инструментов эскиза.
    • Нарисуйте вертикальную линию, привязанную к существующим линиям, и нажмите среднюю кнопку мыши для остановки эскизирования.
    • Нажмите Динамическая Обрезка (Dynamic Trim) на панели инструментов эскиза.
    • Нажмите и протяните через эскиз кривую для удаления ненужных горизонтальных сегментов линий как показано на нижнем рисунке.
    • Проигнорируйте любые размеры на данный момент.

Рисование Линии (Line) и Динамическая Обрезка (Dynamic Trim)

Задача 2-20. Образмеривание и завершение эскиза.
  1. Нажмите Размер (Dimension) на панели инструментов эскиза.
    • Выберите дугу и вертикальную линию, затем нажмите среднюю кнопку мыши для размещения размера.
    • Нажмите среднюю кнопку мыши для остановки рисования и перехода в режим выбора объектов.
    • Дважды кликните на значении размере, введите 8 и нажмите ENTER.

Размер создан

  2. Нажмите Продолжить (Complete Sketch) на панели инструментов эскиза.
  3. Нажмите кнопку Список сохраненных видов (Saved View List) на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
  4. Нажмите Закраска (Shading) на главной панели инструментов.
Задача 2-21. Создание вытягивания, формирующего расширение края модели.
  1. При выбранном эскизе нажмите Выдавливание (Extrude Tool) на панели элементов-фичеров.
    • Нажмите на черную стрелку Опции Глубины (Depth Options Flyout) на инструментальной панели и выберите В Обе Стороны (Both Sides) .
    • Потяните указатель (handle) глубины до 7.
    • Нажмите Применить (Complete Feature) на инструментальной панели.
Tip
Можно нажать правую кнопку мыши на указателях (handles) глубины и выбрать желаемую опцию.

Вытягивание (Protrusion) Создано

Information

Базовые Оси (Datum Axes)

Базовые Оси (Datum Axes) это линейные привязки (references), которые используются для создания других элементов-фичеров.

Задача 2-22. Создание базовой оси (datum axis) и завершение создания модели.

  1. Нажмите Базовые Оси (Datum Axes) на главной панели инструментов (сверху экрана) для включения их отображения.
  2. Нажмите инструмент Базовая Ось (Datum Axis Tool) на панели элементов-фичеров (справа от экрана).
  3. Выберите цилиндрическую поверхность как показано на следующем рисунке и нажмите OK в диалоговом окне (Datum Axis).

Создание Базовой Оси (Datum Axis)

Information

Соосные Отверстия (Coaxial Holes)

Соосные Отверстия (Coaxial Holes) используют базовые оси (datum axis) для центрирования, но также есть необходимость в дополнительной плоскости размещения, как вторичной привязке (secondary reference).

Задача 2-23. Создание соосного отверстия на предыдущей оси.

  1. При выбранной оси нажмите инструмент Отверстие (Hole Tool) на панели элементов-фичеров.
    • Нажмите правой и подождите, затем выберите Коллектор Вторичных Ссылок (Secondary References).
    • Выберите поверхность "D-формы", показанную в верхнем левом углу, как плоскость размещения.
    • Нажмите правой кнопкой мыши на указателе (handle) глубины и задержите, затем выберите Насквозь (Through All).
    • Заметьте, что размер диаметра сохранился от предыдущего отверстия в значении 5 .
    • Нажмите Продолжить (Complete Sketch) на панели инструментов эскиза.

Создание Отверстия (Hole)

  2. Нажмите Базовые оси (Datum Axes) на главной панели инструментов для выключения их отображения.

Information

Выбор нескольких привязок для Скругления (Round)

Нажимайте CTRL для выбора нескольких кромок под простое скругление (single round).

Задача 2-24. Создание скругления (round) для усиления края модели.
  1. Нажмите Скругления (Round Tool) на панели элементов-фичеров.
    • Нажмите CTRL и выберите две внутренние кромки как показано на следующем рисунке.
    • Перетяните указатель (handle) одного из двух радиусов до 3.
    • Нажмите Продолжить (Complete Feature) на инструментальной панели.

Создание Скругления (Round)

Information

Зеркальное отражение (Mirroring) элементов-фичеров

Можно использовать инструмент Зеркальное отражение (Mirror) для зеркального отражения одного или нескольких элементов-фичеров относительно выбранной плоскости.

Задача 2-25.Отражение ряда элементов-фичеров для быстрого создания противоположной стороны модели CONNECTING_ROD.

  1. Нажмите CTRL и выберите следующие четыре элемента-фичера, начиная с низа Дерева Модели (Model Tree) (слева экрана).

Выбор элементов-фичеров

  2. Нажмите Зеркальное отражение (Mirror Tool) на панели элементов-фичеров (справа на экране).
  3. Выберите базовую плоскость RIGHT на Дереве Модели (Model Tree) (слева экрана).
  4. Нажмите Продолжить (Complete Feature) на инструментальной панели.

Элементы-фичеры отражены
Note
Pro/ENGINEER Wildfire имеет специальные инструменты для быстрого дублирования элементов-фичеров; в них входят Зеркальное отражение (Mirror), Копировать/Вставить (Copy/Paste) и Массив (Pattern).

  5. Нажмите Сохранить (Save) на главной панели инструментов и нажмите OK.
  6. Нажмите Файл > Закрыть Окно (File > Close Window) .

Этим завершается второе упражнение.

Урок 3: Создание Сборок (Assemblies).

Обзор - В этом уроке приобретаются навыки моделирования простой сборки (assembly) путем создания сборки и запуска простого механизма (mechanism):

  • PISTON_ASSY.ASM
  • ENGINE.ASM

Сборка ПРОШНЯ (PISTON_ASSY Assembly)

Сборка ДВИГАТЕЛЯ (ENGINE Assembly)

Information

Создание модели Сборки (Assembly)

Новые модели Сборок (Assembly) создаются на основе базового шаблона, который по умолчанию содержит базовые плоскости и координатную систему.

Первый компонент в сборке обычно размещается в позицию По Умолчанию (Default), при которой компонент центрируется в сборке.

Задача 3-1. Создание модели сборки PISTON_ASSY и добавление детали ПОРШЕНЬ (PISTON).

  1. Нажмите Базовые Плоскости (Datum Planes) на главной панели инструментов для включения их отображения.
  2. Нажмите Новый (New) и выберите Сборка (Assembly) в качестве Типа (Type).
  3. Введите PISTON_ASSY в качестве Имени (Name) т нажмите ENTER. Новая модель сборки создалась из базового шаблона.
  4. Нажмите Добавить Компонент (Add Component) на панели элементов-фичеров (справа на экране).
    1. Выберите PISTON.PRT и нажмите Открыть (Open).
    2. Нажмите Позиция по Умолчанию (Default Location) в диалоговом окне Размещение Компонента (Component Placement) и нажмите OK.
  5. Нажмите CTRL и выберите базовые плоскости ASM_RIGHT, ASM_TOP и ASM_FRONT на Дереве Модели (Model Tree).
    1. Нажмите правую и подождите, затем нажмите Скрыть (Hide).

PISTON.PRT добавлен в сборку

Information

Сборка с помощью Привязок (Constraints)

Можно соединять компоненты сборки вместе, создавая различные типы Привязок (Constraints). Привязки могут быть использованы для сборки компонентов в зафиксированную позицию.

Привязки могут быть созданы выбором соответствующих пар геометрии компонента, который добавляется в сборку и компонента, существующего в сборке.

Задача 3-2. Добавление в сборку модели PISTON_PIN с привязками (constraints) Выровнять (Align) и Вставить (Insert).

  1. Нажмите Добавить компонент (Add component) на панели элементов-фичеров.
    1. Выберите модель PISTON_PIN.PRT и нажмите Открыть (Open).
    2. Выберите базовую плоскость FRONT на модели PISTON и модели PISTON_PIN как показано на следующем рисунке.
    3. Заметьте, что получилась привязка Выровнять (Align) в диалоговом окне.

Выбор базовых плоскостей

  2. В случае необходимости, перетяните диалоговое окно Размещение Компонента (Component Placement) вниз для доступа к главной панели инструментов.
  3. Нажмите Базовые Плоскости (Datum Planes) на главной панели инструментов для выключения их отображения.
  4. Выберите цилиндрические поверхности на моделях PISTON.PRT и PISTON_PIN.PRT как показано на следующем рисунке.
    1. Заметьте, что получилась привязка Вставить (Insert) в диалоговом окне.
    2. Нажмите OK в диалоговом окне Размещение Компонента (Component Placement).

Выбор цилиндрических поверхностей

Information

Сборка с помощью Соединений (Connections)

Можно соединять компоненты сборки вместе, создавая различные типы Соединений (Connections). Привязки могут быть использованы для создания реалистичных механических соединений (joints) между компонентами. Эти соединения позволяют компонентам сборки двигаться как механизм.

Соединения могут быть созданы выбором соответствующих пар геометрии компонента, который добавляется в сборку и компонента, существующего в сборке.

Соединение Ось (Pin) позволяет вращать компонент, но не перемещать вдоль оси вращения.

Задача 3-3. Начало сборки модели CONNECTING_ROD с соединением типа Ось (Pin).

  1. Нажмите Добавить компонент (Add component) на панели элементов-фичеров.
    1. Выберите модель CONNECTING_ROD.PRT и нажмите Открыть (Open).
    2. Выберите закладку Соединить (Connect) в диалоговом окне Размещение Компонента (Component Placement).
    3. Заметьте, что по умолчанию установлено соединение Ось (Pin).
    4. Нажмите и удерживайте среднюю кнопку мыши для вращения сборки, и затем выберите цилиндрические поверхности как показано на следующем рисунке.

Выбор цилиндрических поверхностей

  2. Нажмите Список сохраненных видов (Saved View List) на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).
Information

Использование Инструмента Поиска (Search Tool)

Инструмент поиска (Search Tool) обеспечивает легкий способ выбора элементов, которые не отображаются.

В нашем случае базовые плоскости должны быть выбраны для выравнивания модели CONNECTING_ROD с центром модели PISTON.

Задача 3-4. Завершение соединения типа Ось (Pin) модели CONNECTING_ROD.

  1. Поиск первой базовой плоскости:
    1. Нажмите Инструмент поиска (Search Tool) на главной панели инструментов.
    2. Выберите Базовая Плоск (Datum Plane) в выпадающем списке "Искать для" (Look For).
    3. Выберите модель PISTON.PRT в выпадающем списке "Просмотр в" (Look In).
    4. Нажмите Поиск (Find Now), выберите базовую плоскость FRONT и нажмите Добавить (Add Item) .
    5. Нажмите Закрыть (Close).
  2. Поиск второй базовой плоскости:
    1. Нажмите Инструмент поиска (Search Tool) на главной панели инструментов снова и нажмите Поиск (Find Now).
    2. Выберите базовую плоскость FRONT и нажмите Добавить (Add Item) , затем нажмите Закрыть (Close).
    3. Теперь соединение типа Ось (Pin) определено. Нажмите OK в диалоговом окне Размещение Компонента (Component Placement).
  3. Нажмите Переместить Компонент (Drag Component) на главной панели инструментов.
    1. Нажмите и получите двигающееся соединение тяги как показано на рисунке ниже.
    2. Кликните для принятия нового положения.
    3. Нажмите среднюю кнопку мыши, когда закончите.

PISTON_ASSY.ASM

  4. Нажмите Сохранить (Save) на главной панели инструментов и нажмите OK.
  5. Нажмите Файл > Закрыть Окно (File > Close Window) .
Задача 3-5. Открытие сборки модели ДВИГАТЕЛЯ (ENGINE).
  1. Нажмите Навигатор Папок (Folder Browser) (слева экрана) и выберите папку ProE_models.
  2. Выберите модель ENGINE.ASM из браузера и нажмите Открыть файл в Pro/E (Open File in Pro/E) .

Note
Модель ENGINE_BLOCK.PRT должна быть прозрачной внутри сборки ENGINE.ASM.

ENGINE.ASM

Information

Запуск Механизма (Mechanism)

Механизм (Mechanism) ссылается на компоненты, которые были собраны при помощи Соединений (Connections). Соединения (Connections) могут быть использованы для разрешения движения компонентов, похожему на реалистичное.

Вы можете выбрать Режим Механизма (Mechanism Mode) для того, чтобы запустить механизм. Для запуска его надлежащим образом, сборка должна иметь компоненты собранные с помощью соединений, а также необходимо определить Сервопривод (Servo Motor) и Анализ (Analysis).

Сервопривод (Servo Motor) определяет скорость вращения коленчатого вала (crankshaft), а Анализ (Analysis) определяет время вращения запущенного механизма.

Сборка ДВИГАТЕЛЯ (ENGINE) создавалась с использованием соединения типа Ось (Pin) для модели КОЛЕНВАЛ (CRANKSHAFT). Сервопривод (Servo Motor) (90 градусов/сек) и Анализ (Analysis) (4 сек) были созданы до Вас, и обеспечивают вращение на 360 градусов.

Задача 3-6. Запуск существующего механизма.

  1. Нажмите Приложения > Механизм (Applications > Mechanism) в главном меню.
    1. Нажмите Выполнить Анализ (Run Analysis) на панели инструментов Механизма (справа на экране).
    2. Выберите имя RUN_ENGINE и нажмите Выполнить (Run).
    3. Заметьте, что КОЛЕНВАЛ (CRANKSHAFT) прокрутился на 360 градусов.
    4. Нажмите Закрыть (Close) в диалоговом окне Анализы (Analyses).
  2. Нажмите Приложения > Стандартное (Applications > Standard) в главном меню.
    1. Нажмите Да (Yes) в появившемся окне сообщений.
  3. Нажмите Список сохраненных видов (Saved View List) на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).

    4. Information

    Сборка с помощью Соединений (Connections)

    Цилиндрическое (Cylinder) соединение позволяет вращать и перемещать компонент вдоль оси (axis) вращения.

    Задача 3-7. Добавление модели PISTON_ASSY в сборку ДВИГАТЕЛЯ (ENGINE), затем создание Цилиндрического (Cylinder) соединения.

    1. Нажмите Добавить компонент (Add component) на панели элементов-фичеров.
    2. Выберите модель PISTON_ASSY.ASM и нажмите Открыть (Open).
    3. Создайте цилиндрическое соединение как показано на следующем рисунке:
      • Нажмите совместно CTRL + ALT, затем нажмите и задержите правую кнопку мыши для перемещения модели PISTON_ASSY.ASM в положение, показанное на рисунке.
      • Выберите закладку Соединить (Connect) в диалоговом окне Размещение Компонента (Component Placement).
      • Измените Тип (Type) соединения с Ось (Pin) на Цилиндрический (Cylinder).
      • Выберите цилиндрические поверхности как показано на рисунке.

    Выбор поверхностей

    Задача 3-8. Создание второго цилиндрического соединения в модели PISTON_ASSY.
    1. Создайте цилиндрическое соединение как показано на следующем рисунке:
      • Нажмите и задержите среднюю кнопку мыши для поворота всей сборки как показано на рисунке сверху слева.
      • Нажмите CTRL, нажмите и удерживайте среднюю кнопку мыши, и передвиньте мышь к себе для приближения вида.
      • Нажмите совместно CTRL + ALT, затем нажмите и задержите левую кнопку мыши для перемещения модели CRANKSHAFT (КОЛЕНВАЛ) в положение, показанное на рисунке сверху справа.
      • Нажмите Новое Закрепление (New Constraint) в диалоговом окне Размещение Компонента (Component Placement).
      • Увеличьте модель и выберите цилиндрические поверхности как показано на рисунке снизу.

    Выбор поверхностей

    2. Нажмите совместно CTRL + ALT, затем нажмите и задержите левую кнопку мыши для перемещения модели CRANKSHAFT (КОЛЕНВАЛ) снова.
      1. Ось модели CRANKSHAFT (КОЛЕНВАЛ) может теперь выравниваться с отверстием в модели CONNECTING_ROD, и модель PISTON_ASSY может теперь вращаться совместно с CRANKSHAFT (КОЛЕНВАЛОМ).
      2. Нажмите OK в диалоговом окне Размещение Компонента (Component Placement).
      3. Нажмите Список сохраненых видов (Saved View List) на главной панели инструментов и выберите Стандартная ориентация (Standard Orientation).

    Соединения (Connections) завершены

    Information

    Запуск Механизма (Mechanism)

    Вы можете выбрать Режим Механизма (Mechanism Mode) для того, чтобы запустить механизм. После того, как модель PISTON_ASSY была собрана с использованием соединений, можно посмотреть вращение КОЛЕНВАЛА (CRANKSHAFT).

    Задача 3-9. Запуск механизма ДВИГАТЕЛЯ (ENGINE) снова.
    1. Нажмите Приложения > Механизм (Applications > Mechanism) в главном меню
      1. Нажмите Выполнить Анализ (Run Analysis) на панели инструментов Механизма (справа на экране).
      2. Выберите имя RUN_ENGINE и нажмите Выполнить (Run). Заметьте, что механизм прокрутился на 360 градусов.
      3. Нажмите Закрыть (Close) в диалоговом окне Анализы (Analyses).
    2. Нажмите Сохранить (Save) на главной панели инструментов и нажмите OK.
    3. Нажмите Файл > Закрыть Окно (File > Close Window) и нажмите Да (Yes) в появившемся окне сообщений.
    4. Нажмите Файл > Стереть > Невидимые > OK (File > Erase > Not Displayed > OK) для стирания всех моделей из памяти сессии.

    Этим завершается третье упражнение.

    ПОЗДРАВЛЯЕМ !

    Вы завершили раздел по моделированию деталей и сборок этого учебника.

    Если Вы желаете, то, пожалуйста, продолжите вторую часть упражнений, бросив вызов:

    • Созданию Чертежей (Drawings) (10 страниц)
    • Ассоциативности Модели (Model Associativity) (5 страниц)

    РЕЗЮМЕ

    Теперь заметим, что Вы завершили эту секцию учебника и способны:

    • Описать основы Pro/ENGINEER Wildfire.
    • Управлять интерфейсом Pro/ENGINEER Wildfire.
    • Делать предпросмотр, открытие и ориентацию разработанных моделей.
    • Создавать простые модели деталей.
    • Создавать сборку.
    • Запускать простой механизм.

    Упражнение 4: Создание Чертежей (Drawings) (ВЫЗОВ).

    ОБЗОР - в этом упражнении приобретаются навыки создания простого чертежа (drawing) путем создания 2-х листового чертежа, названного ENGINE_COMPONENTS; разброс по деталям сборки ДВИГАТЕЛЯ (ENGINE) и ШАТУНА (CONNECTING_ROD):

    • ENGINE_COMPONENTS.DRW - лист 1 (sheet 1)
    • ENGINE_COMPONENTS.DRW - лист 2 (sheet 2)

    Чертеж ENGINE_COMPONENTS.DRW - лист 1 и 2 (sheet 1 and 2)

    Задача 4-1. Открытие сборки ENGINE_COMPLETE.
    1. Выберите закладку Навигатор Папок (Folder Browser) и выберите папку ProE_models.
    2. Выберите модель ENGINE_COMPLETE.ASM в браузере и нажмите Открыть в Pro/E (Open File in Pro/E) .

    ENGINE_COMPLETE.ASM

    Information

    Сечения (Cross Sections)

    Существует два различия между моделью ENGINE_COMPLETE.ASM и тем, что было создано Вами: в отрытой модели уже созданы Сечение (Cross Section) и Разнесенный Вид (Explode State). Они будут использоваться для создания чертежа.

    Сечения (Cross Sections) позволяют определять "разрез" детали или сборки на виде.

    Задача 4-2. Исследование сечения сборки ENGINE_COMPLETE.

    1. Нажмите Менеджер Видов (View Manager) на главной панели инструментов.
      • Выберите закладку Сечения (Xsec) и дважды нажмите на A для обзора сечения.
      • Нажмите Отображение > Поворот (Display > Flip) в диалоговом окне Менеджер Видов (View Manager).
      • Дважды нажмите на Нет Сечения (No Cross Section).

    Сечение А (Cross Section A)

    Information

    Разнесенные виды (Explode States)

    Существует два различия между моделью ENGINE_COMPLETE.ASM и тем, что было создано Вами: в отрытой модели уже созданы Сечение (Cross Section) и Разнесенный Вид (Explode State). Они будут использоваться для создания чертежа.

    Разнесенные виды (Explode States) позволяют определить "разобранный" вид сборки.

    Задача 4-3. Исследование разнесенного вида в сборке ENGINE_COMPLETE.

    1. В диалоговом окне Менеджер Видов (View Manager) выберите закладку Разнесенный (Explode).
      • Дважды нажмите на Exp_1 для обзора разнесенного вида.
      • Нажмите правой кнопкой мыши в диалоговом окне Менеджер Видов (View Manager) и выберите Собрать (Unexplode).
      • Нажмите Закрыть (Close) в диалоговом окне Менеджер Видов (View Manager).

    Разнесенный вид Exp_1

    Information

    Создание Чертежей (Drawings)

    Режим Чертежа (Drawing) позволяет размещать плоские и аксонометрические (2D и 3D) виды модели детали или сборки на плоском (2D) чертежном листе для производственных целей.

    Можно быстро создавать чертежи, использую Чертежный Шаблон (Drawing Template). Чертежный Шаблон (Template) содержит предопределенное расположение видов и может содержать форматку с титульным блоком.

    Этот специфический шаблон может быть использован в различных комбинациях сборок с похожими результатами.

    Задача 4-4. Создание чертежа сборки ENGINE_COMPLETE с использованием шаблона.

    1. Нажмите Файл > Закрыть Окно (File > Close Window) .
    2. Нажмите Новый (New) и выберите Чертеж (Drawing) в качестве Типа (Type).
    3. Введите ENGINE_COMPONENTS в качестве Имени (Name) и нажмите ENTER.
    4. Заметьте, что ENGINE_COMPLETE.ASM используется как Модель По Умолчанию (Default Model), и что текущим шаблоном является drawing_template.
    5. Нажмите OK в диалоговом окне Новый Чертеж (New Drawing).
    6. Введите информацию параметра для создания чертежа как показано на следующем рисунке:
      • Введите Ваше Имя (YOUR NAME) на запрос и нажмите ENTER.
      • Создался новый чертеж, который использует шаблон для размещения 4 изометрических видов, разнесенный вид, титульный блок и спецификацию (bill of materials - BOM).
      • Дважды нажмите на графу с датой (date) в титульном блоке напротив Вашего имени и введите &todays_date.
      • Нажмите OK в диалоговом окне Свойства Заметки (Note Properties).
    Note
            Слово '&todays_date' ("текущая дата") использует системный параметр для отображения даты.

    Чертеж создан

    Information

    Создание Чертежей (Drawings)

    В дополнение к используемому чертежному Шаблону (Template) можно размещать виды на листе чертежа вручную. Сначала размещается Общий (General) вид. Общий (General) вид может быть размещен в любой ориентации.

    Задача 4-5. Добавление второго листа и создание вида модели CONNECTING_ROD.

    1. Нажмите на фон чертежа, затем нажмите правую кнопку мыши и выберите Свойства (Properties).
      1. Нажмите Модели Чертежа > Добав Модель (Drawing Models > Add Model) в менеджере меню (справа от экрана).
      2. Выберите модель CONNECTING_ROD_COMPLETE.PRT и нажмите Открыть (Open).
    2. Нажмите Вставить > Лист (Insert > Sheet) в главном меню для добавления второго листа в чертеж.
      1. Введите Ваше Имя (YOUR NAME) на запрос и нажмите ENTER.
    3. Нажмите правую кнопку мыши и выберите Вставить Общий Вид (Insert General View).
      1. Выберите точку расположения как показано на следующем рисунке для размещения вида.

    Размещение Общего Вида (General View).

    4. Выберите FRONT(фронтальный) в качестве Имени Вида Модели (Model View Name) и нажмите OK в диалоговом окне Вид Чертежа (Drawing View).
    5. Дважды кликните на тексте МАСШТАБ (SCALE) в нижнем левом углу листа, введите 5 и нажмите ENTER.
    Information

    Создание Чертежей (Drawings)

    Поскольку Общий (General) вид размещен, можно создавать другие виды, например Проекционные (Projection) виды.

    Задача 4-6. Размещение проекционных видов CONNECTING_ROD.

    1. Создайте проекционный вид как показано на следующем рисунке:
      • Выберите предыдущий вид FRONT (фронтальный).
      • Нажмите правую кнопку мыши и выберите Вставить Проекционный Вид (Insert Projected View).
      • Выберите расположение над первым видом как показано на следующем рисунке.

    Размещение первого Проекционного Вида (Projection View)

    2. Создайте другой проекционный вид как показано на следующем рисунке:
      • Выберите вид FRONT (фронтальный) снова.
      • Нажмите правую кнопку мыши и выберите Вставить Проекционный Вид (Insert Projected View).
      • Выберите расположение справа первого вида как показано на следующем рисунке.

    Размещение второго Проекционного Вида (Projection View)

    Information

    Создание Чертежей (Drawings)

    Общие (General) виды могут быть расположены в 2D или 3D ориентациях.

    Задача 4-7. Размещение 3D общего вида модели CONNECTING_ROD.

    1. Нажмите на фон для снятия выбора с текущего вида.
    2. Нажмите правую кнопку мыши и выберите Вставить Проекционный Вид (Insert Projected View).
      • Выберите точку расположения как показано на следующем рисунке для размещения вида.
      • Нажмите OK в диалоговом окне Вид Чертежа (Drawing View).
      • Нажмите правую кнопку мыши и выберите Блокировать Движение Видов (Lock View Movement) чтобы снять галочку.
      • Выберите и перетяните виды, в случае необходимости, в позицию, показанную на рисунке.

    Размещение 3D Общего Вида.

    Information

    Стили Показа (Display Style) вида

    Вы можете изменить Стиль Показа (Display Style) вида, вызвав Свойства (Properties) вида. Стили Показа (Display Styles) вида содержат режимы отображения: Нет Скрытых (No Hidden), Скрытые Линии (Hidden Lines) и Каркасный (Wireframe).

    Задача 4-8. Установите стиль показа для видов TOP (верхний) и RIGHT (правый) в режим отображения скрытых линий (hidden lines).

    1. Нажмите на фон для снятия выбора с текущего вида, в случае необходимости.
    2. Установите стиль показа для двух видов:
      1. Нажмите CTRL и выберите проекционные виды TOP (верхний) и RIGHT (правый).
      2. Нажмите правую кнопку мыши и выберите Свойства (Properties). Выберите тип Скрытые (Hidden) в качестве Стиля Показа (Display Style) и нажмите OK.

    Скрытые линии (Hidden Lines) отобразились

    Information

    Отображение размеров (Dimensions)

    Можно быстро Показать Размеры (Show Dimensions), созданные в модели детали. Размеры создавались в процессе моделирования элементов-фичеров; это размеры эскиза или размер глубины отверстия, введенный позже.

    Задача 4-9. Показ и упорядочивание размеров на видах FRONT (фронтальный) и TOP (верхний).

    1. Выберите вид FRONT (фронтальный), затем нажмите правую и выберите Показать Размеры (Show Dimensions).
    2. Нажмите CTRL, нажмите и удерживайте среднюю кнопку мыши, и передвиньте мышь к себе для приближения вида.
    3. Выберите размер 8, затем передвиньте его на место, показанное на следующем рисунке.

    Размер передвинут

    Information

    Упорядочивание (Cleaning Up) размеров

    Можно быстро Упорядочить Размеры (Cleanup Dimensions) на виде, после того как они будут показаны. Это дистанцирует их относительно вида. Только линейные размеры могут быть упорядочены.

    Задача 4-10. Показ и упорядочивание размеров на видах FRONT (фронтальный) и TOP (верхний).
    1. Нажмите на вид FRONT (фронтальный), затем нажмите правую и выберите Упорядочить Размеры (Cleanup Dimensions).
      1. Введите по 0.5 в графы Смещение (Offset) и Приращение (Increment) в диалоговом окне Упорядочить Размеры (Clean Dimensions).
      2. Снимите галочку в пункте Создать Линии Привязки (Create Snap Lines) и нажмите Применить > Закрыть (Apply > Close).
    2. Нажмите Вписать (Refit) на главной панели инструментов.
    3. Выберите вида TOP (сверху), нажмите правую и выберите Показать Размеры (Show Dimensions).
    4. Нажмите правую снова и выберите Упорядочить Размеры (Cleanup Dimensions).
    5. Нажмите Применить > Закрыть (Apply > Close).
    Information

    Управление Размерами

    Поскольку размеры показаны и упорядочены, можно дополнительно манипулировать ими. Когда размер выбран, появляется несколько указателей (handles) управления ими:

    • Указатель (Handle) в центре текста - Сместить размер.
    • Любой из указателей (Handles) в стороне от текста - Смещение размерного текста.
    • Указатели (Handles) на концах вспомогательных линий - Выравнивание выносных линий.

    Несколько опций редактирования дополнительных размеров также доступны после выбора размера (-ов) и вызываются из меню по правой кнопке мыши.

    Задача 4-11. Управление размерами на видах FRONT (фронтальный) и TOP (верхний).

    1. Разместите указатель мыши между видами FRONT (фронтальный) и TOP (верхний).
      1. Нажмите CTRL, нажмите и удерживайте среднюю кнопку мыши, и передвиньте мышь к себе для приближения вида.
    2. Управляйте размерами как показано на следующем рисунке:
      • Выберите диаметральный размер 8.5, нажмите правой и выберите Повернуть Стрелки (Flip Arrows).
      • Выберите диаметральный размер 5, нажмите правой и выберите Повернуть Стрелки (Flip Arrows). Затем перетяните размер в позицию, показанную на рисунке. Перетяните указатель (handle), расположенный за размерным текстом для перемещения текста налево от выноски.
      • Выберите размер 8. Нажмите и перетяните указатели (handles) на концах выносных линий в позицию, показанную на рисунке.
      • Выберите радиусный размер 3. нажмите правой и выберите Повернуть Стрелки (Flip Arrows) дважды. Затем перетяните размер в позицию, показанную на рисунке. Перетяните указатель (handle), расположенный за размерным текстом для перемещения текста направо от выноски.
      • Выберите размер 7. Нажмите и перетяните указатели (handles) на концах выносных линий в позицию, показанную на рисунке.

    Размеры перепозиционированы

    Information

    Создание размеров

    Можно использовать опцию Создать размер (Create Dimension) для создания размера на чертеже для геометрии, которая не образмерена.

    Созданный таким образом размеры часто обозначается как Справочный (Driven) размер, поскольку он управляется геометрией и обновляется при изменении, но не может быть напрямую отредактирован.

    Задача 4-12. Создание размера для обозначения габаритной длины модели CONNECTING_ROD.

    1. Нажмите Создать размер (Create Dimension) на панели инструментов чертежа.
      1. Выберите кромки как показано на следующем рисунке.

    Выбор Кромок (Edges)

    2. Нажмите среднюю кнопку мыши над размером 33 для размещения размера.
      1. Нажмите Касательно > Касательно > Горизонтальный > Вернуться (Tangent > Tangent > Horizontal > Return) в менеджере меню (справа от экрана).

    Справочный (Driven) размер создан

    3. Нажмите на вид FRONT (фронтальный), нажмите правую и выберите Упорядочить размеры (Cleanup Dimensions).
      1. Нажмите Применить > Закрыть (Apply > Close). Заметьте, что созданный размер дистанцировался соответствующим образом.
    4. Нажмите Вписать (Refit) на главной панели инструментов.
    5. Нажмите Сохранить (Save) и затем нажмите OK.
    6. Нажмите Файл > Закрыть Окно (File > Close Window) .

    Этим завершается четвертое упражнение.

    Упражнение 5: Ассоциативность (Associativity) модели (ВЫЗОВ).

    Обзор - В этом упражнении Вы будете экспериментировать с ассоциативностью между режимами деталь, сборка и чертеж. Ассоциативность (Associativity) позволяет проводить изменения в одном из режимов, для того чтобы изменения отразились в других режимах. Вы будете выполнять следующие задачи:

    • Модификация модели детали и просмотр обновления сборки.
    • Исследование взаимопроникновения (interference) деталей в сборке.
    • Модификация размера в чертеже и просмотр обновления детали.
    • Пересмотр сборки для проверки разрешения ситуации с взаимопроникновением (interference) .
    Задача 5-1. изменение размера тела модели CONNECTING_ROD для ее удлинения.
    1. Выберите Навигатор Папок (Folder Browser) и выберите папку ProE_models.
      1. Выберите модель ENGINE_COMPLETE.ASM из браузера и нажмите Открыть Файл в Pro/E (Open File in Pro/E) .
    Note
            ВАЖНО - следующим шагом Вы будете открывать второе окно Pro/ENGINEER. Вы должны изменить размеры и положение окна справа от учебника.

    2. Нажмите '+' для раскрытия модели PISTON_ASSY_COMPLETE в дереве модели.
      1. Выдерите модель CONNECTING_ROD_COMPLETE.
      2. Нажмите правой и подождите, затем нажмите Открыть (Open).
    3. Дважды кликните на середину модели для отображения размеров элемента-фичера ВЫТЯГИВАНИЕ 1 (EXTRUDE 1).
    4. Дважды кликните на размере 33, введите 30 и нажмите ENTER.

    Редактирование размера

    5. Нажмите Обновить (Regenerate) на главной панели инструментов для обновления модели.
      Tip
              Также можно нажать совместно CTRL + G для регенерации модели.
    Задача 5-2. Регенерация сборки для обзора эффекта сокращения модели CONNECTING_ROD.
    1. Нажмите Окно (Window) > ENGINE_COMPLETE.ASM в главном меню.
    2. Нажмите Обновить (Regenerate) на главной панели инструментов.
      1. Сборка слегка изменилась, что обусловлено укорочением модели CONNECTING_ROD.PRT.

    Обновление сборки

    Information

    Выполнение проигрывания Механизма (Mechanism)

    Поскольку Анализ Механизма (Mechanism Analysis) ранее был выполнен, то можно использовать опцию Проиграть Анализ (Replay Analysis) для 'анимации' механизма в режиме непрерывного воспроизведения. Можно также использовать опцию Общее Взаимопроникновение (Global Interference) для проверки на любое взаимопроникновение между компонентами в процессе воспроизведения.

    Задача 5-3. Выполнение проигрывания механизма для просмотра взаимопроникновения, полученного из-за укорочения модели CONNECTING_ROD.

    1. Нажмите Приложения > Механизм (Applications > Mechanism) в главном меню.
      • Нажмите Выполнить Анализ (Run Analysis) на панели инструментов механизма (справа от экрана).
      • Выберите имя RUN_ENGINE и нажмите Выполнить (Run) в диалоговом окне Анализы (Analyses). Затем нажмите Закрыть (Close).
      • Нажмите Проиграть Анализы (Replay Analysis) на панели инструментов механизма (справа от экрана).
      • Выберите Общее Взаимопроникновение (Global Interference) и нажмите Проиграть (Play) в диалоговом окне Анимация (Playbacks). (взаимопроникновение будет вычисляться несколько секунд).
      • Перетяните ползунок Скорость (Speed) на максимум и нажмите Проиграть (Play) в диалоговом окне Анимация (Playbacks).
      • Заметьте, что в процессе движения происходит взаимопроникновение (красная подсветка) внизу поршня.

    Взаимопроникновение (Interference) обнаружено

    2. Нажмите Стоп (Stop) , когда закончите просмотр взаимопроникновения, и затем нажмите Закрыть > Закрыть (Close > Close).
    3. Нажмите Переместить Компонент (Drag Component) на панели инструментов механизма (справа от экрана).
    4. Дважды кликните на имя Snaphot1 и нажмите Закрыть (Close).
    5. Нажмите Приложения > Стандартное (Applications > Standard) в главном меню и нажмите Да (Yes) в окне сообщений.
    6. Нажмите Файл > Закрыть Окно (File > Close Window) для возвращения в деталь CONNECTING_ROD.
    Задача 5-4. Обзор эффектов в чертеже и модификация модели CONNECTING_ROD путем возвращения длины в ее начальное значение.

    Note
            ВАЖНО - следующим шагом Вы будете открывать второе окно Pro/ENGINEER. Вы должны изменить размеры и положение окна справа от учебника.

    1. Выберите Навигатор Папок (Folder Browser) и выберите папку ProE_models.
      1. Выберите модель ENGINE_COMPONENTS.DRW из браузера для обзора в окне предпросмотра.
      2. Нажмите Следующий Лист (Next Sheet) , затем нажмите Открыть в Pro/E (Open in Pro/E) .
      3. Заметьте, что в чертеже открылся сразу Лист 2 (Sheet 2).
    2. Разместите указатель мыши между видами FRONT (фронтальный) и TOP (верхний).
      1. Нажмите CTRL, нажмите и удерживайте среднюю кнопку мыши, и передвиньте мышь к себе для приближения вида.
      2. Заметьте, что чертежные виды и размеры обновлены до новой длины 30.

    Обновление чертежа

    3. Выберите размер 30. Дважды кликните на значении 30, введите 33 и нажмите ENTER.
    4. Нажмите Обновить (Regenerate) на главной панели инструментов.
      1. Заметьте, что чертежные виды и размеры обновились.
    5. Нажмите Окно (Window) > CONNECTING_ROD_COMPLETE.PRT для просмотра детали.
      1. Дважды кликните на середину модели для отображения размеров элемента-фичера ВЫТЯГИВАНИЕ 1 (EXTRUDE 1).
      2. Заметьте, что размер элемента-фичера обновлен до предыдущего значения 33.
    6. Нажмите Файл > Закрыть Окно ( File > Close Window) дважды для закрытия обоих окон.
    Задача 5-5. (На усмотрение) Перепроверка взаимопроникновения (Interference) на верхнем уровне сборки.
    1. Выберите Навигатор Папок (Folder Browser) и выберите папку ProE_models.
      1. Выберите модель AC-40.ASM из браузера для обзора в окне предпросмотра.
      2. Нажмите Открыть в Pro/E (Open in Pro/E) .
    2. Нажмите Переместить Компонент (Drag Component) на главной панели инструментов.
      1. Выберите любую крыло крыльчатки (внутреннего вентилятора) и потяните механизм.
      2. Нажмите среднюю кнопку мыши для завершения перетягивания.
    3. Запустите механизм и наблюдайте любое взаимопроникновение как показано на следующем рисунке:
      • Нажмите Приложения > Механизм (Applications > Mechanism) в главном меню.
      • Нажмите Выполнить Анализ (Run Analysis) на панели инструментов механизма.
      • Выберите имя RUN_ENGINE и нажмите Выполнить (Run). Нажмите Закрыть (Close) в диалоговом окне Анализы (Analyses).
      • Нажмите Проиграть Анализы (Replay Analysis) на панели инструментов механизма.
      • Выберите Общее Взаимопроникновение (Global Interference) и нажмите Проиграть (Play) в диалоговом окне Анимация (Playbacks). (взаимопроникновение будет вычисляться несколько секунд).
      • Перетяните ползунок Скорость (Speed) на максимум и нажмите Проиграть (Play) в диалоговом окне Анимация (Playbacks).
      • Заметьте, что взаимопроникновения не происходит.

    Взаимопроникновение (interference) не обнаружено

    4. Нажмите Стоп (Stop) , когда закончите просмотр взаимопроникновения, и затем нажмите Закрыть > Закрыть (Close > Close).
    5. Нажмите Приложения > Стандартное (Applications > Standard) в главном меню и нажмите Да (Yes) в окне сообщений.
    6. Нажмите Сохранить (Save) и затем нажмите OK.

    Этим завершается пятое упражнение.

    ПОЗДРАВЛЕНИЯ !

    Теперь Вы завершили Учебник начального курса.

    РЕЗЮМЕ

    Теперь Вы завершили этот учебник и можете:

    • Описать основы Pro/ENGINEER Wildfire.
    • Управлять интерфейсом Pro/ENGINEER Wildfire.
    • Делать предпросмотр, открытие и ориентацию разработанных моделей.
    • Создавать простые модели деталей.
    • Создавать сборку.
    • Запускать простой механизм.
    • Создавать чертеж с видами сборки и детали.
    • Отображать и управлять размерами на чертежных видах.
    • Модифицировать модель и исследовать обновление сборки и чертежа.
    • Проверять взаимопроникновения в сборке.

    Хотите получить лучшее в своем роде обучение Pro/ENGINEER без неудобных и затратных поездок?

    Это просто – только свяжитесь с PTC University! PTC University это онлайновый портал, который включает глубину и ширину программ традиционного обучения компании PTC с удобством, гибкостью и экономичностью дистанционного образования.

    С помощью PTC University Вы имеете доступ к множеству эффективных форм дистанционного обучения, включая Виртуальные Классы (Virtual Classes), Веб-ориентированный тренинг (Web-based Training), Активы электронных Знаний (e-Knowledge Assets) и Сообщество Практикующих (Communities of Practice).

    Или Вы хотите совершенствовать Ваши существующие навыки, или изучать новую технику работы, PTC University даст Вам верную информацию в нужное время с аудиовизуальным сопровождением - всегда с комфортом для Вас.

    Изучайте больше в PTC University, который может помочь Вам улучшить разработку Ваших знаний продуктов www.ptc.com/go/learning.

    Copyright © 2004 Parametric Technology Corporation. All Rights Reserved.

    User and training documentation from Parametric Technology Corporation (PTC) is subject to the copyright laws of the United States and other countries and is provided under a license agreement that restricts copying, disclosure, and use of such documentation. PTC hereby grants to the licensed user the right to make copies in printed form of this documentation if provided on software media, but only for internal/personal use and in accordance with the license agreement under which the applicable software is licensed. Any copy made shall include the PTC copyright notice and any other proprietary notice provided by PTC. This documentation may not be disclosed, transferred, modified, or reduced to any form, including electronic media, or transmitted or made publicly available by any means without the prior written consent of PTC and no authorization is granted to make copies for such purposes.

    Information described herein is furnished for general information only, is subject to change without notice, and should not be construed as a warranty or commitment by PTC. PTC assumes no responsibility or liability for any errors or inaccuracies that may appear in this document.

    The software described in this document is provided under written license agreement, contains valuable trade secrets and proprietary information, and is protected by the copyright laws of the United States and other countries. It may not be copied or distributed in any form or medium, disclosed to third parties, or used in any manner not provided for in the software licenses agreement except with written prior approval from PTC. UNAUTHORIZED USE OF SOFTWARE OR ITS DOCUMENTATION CAN RESULT IN CIVIL DAMAGES AND CRIMINAL PROSECUTION.

    Parametric Technology Corporation, 140 Kendrick Street, Needham, MA 02494 USA

    Registered Trademarks of Parametric Technology Corporation or a Subsidiary
    Advanced Surface Design, Behavioral Modeling, CADDS, Computervision, CounterPart, EPD, EPD.Connect, Expert Machinist, Flexible Engineering, GRANITE, HARNESSDESIGN, Info*Engine, InPart, MECHANICA, Optegra, Parametric Technology, Parametric Technology Corporation, PartSpeak, PHOTORENDER, Pro/DESKTOP, Pro/E, Pro/ENGINEER, Pro/HELP, Pro/INTRALINK, Pro/MECHANICA, Pro/TOOLKIT, Product First, PTC, the PTC logo, PT/Products, Shaping Innovation, and Windchill.

    Trademarks of Parametric Technology Corporation or a Subsidiary
    3DPAINT, Associative Topology Bus, AutobuildZ, CDRS, Create Collaborate Control, CV, CVact, CVaec, CVdesign, CV-DORS, CVMAC, CVNC, CVToolmaker, DataDoctor, DesignSuite, DIMENSION III, DIVISION, e/ENGINEER, eNC Explorer, Expert MoldBase, Expert Toolmaker, ISSM, KDiP, Knowledge Discipline in Practice, Knowledge System Driver, ModelCHECK, MoldShop, NC Builder, Pro/ANIMATE, Pro/ASSEMBLY, Pro/CABLING, Pro/CASTING, Pro/CDT, Pro/CMM, Pro/COLLABORATE, Pro/COMPOSITE, Pro/CONCEPT, Pro/CONVERT, Pro/DATA for PDGS, Pro/DESIGNER, Pro/DETAIL, Pro/DIAGRAM, Pro/DIEFACE, Pro/DRAW, Pro/ECAD, Pro/ENGINE, Pro/FEATURE, Pro/FEM-POST, Pro/FICIENCY, Pro/FLY-THROUGH, Pro/HARNESS, Pro/INTERFACE, Pro/LANGUAGE, Pro/LEGACY, Pro/LIBRARYACCESS, Pro/MESH, Pro/Model.View, Pro/MOLDESIGN, Pro/NC-ADVANCED, Pro/NC-CHECK, Pro/NCMILL, Pro/NCPOST, Pro/NC-SHEETMETAL, Pro/NC-TURN, Pro/NC-WEDM, Pro/NC-Wire EDM, Pro/NETWORK ANIMATOR, Pro/NOTEBOOK, Pro/PDM, Pro/PHOTORENDER, Pro/PIPING, Pro/PLASTIC ADVISOR, Pro/PLOT, Pro/POWER DESIGN, Pro/PROCESS, Pro/REPORT, Pro/REVIEW, Pro/SCAN-TOOLS, Pro/SHEETMETAL, Pro/SURFACE, Pro/VERIFY, Pro/Web.Link, Pro/Web.Publish, Pro/WELDING, Product Development Means Business, ProductView, PTC Precision, Shrinkwrap, Simple Powerful Connected, The Product Development Company, The Way to Product First, Wildfire, Windchill DynamicDesignLink, Windchill PartsLink, Windchill PDMLink, Windchill ProjectLink, and Windchill SupplyLink.

    Patents of Parametric Technology Corporation or a Subsidiary

    Additional foreign equivalents may be issued or pending – contact PTC for further information:

    Registration No. Issue Date
    6,665,569 B1 16-December-2003
    6,625,607 B1 23-September-2003
    6,580,428 B1 17-June-2003
    GB2354684B 02-July-2003
    GB2384125 15-October-2003
    GB2354096 12-November-2003
    6,608,623 B1 19 August 2003
    GB2353376 05-November-2003
    GB2354686 15-October-2003
    6,545,671 B1 08-April-2003
    GB2354685B 18-June-2003
    6,608,623 B1 19 August-2003
    6,473,673 B1 29-October-2002
    GB2354683B 04-June-2003
    6,447,223 B1 10-Sept-2002
    6,308,144 23-October-2001
    5,680,523 21-October-1997
    5,838,331 17-November-1998
    4,956,771 11-September-1990
    5,058,000 15-October-1991
    5,140,321 18-August-1992
    5,423,023 05-June-1990
    4,310,615 21-December-1998
    4,310,614 30-April-1996
    4,310,614 22-April-1999
    5,297,053 22-March-1994
    5,513,316 30-April-1996
    5,689,711 18-November-1997
    5,506,950 09-April-1996
    5,428,772 27-June-1995
    5,850,535 15-December-1998
    5,557,176 09-November-1996
    5,561,747 01-October-1996

    Third-Party Trademarks
    Adobe is a registered trademark of Adobe Systems. Advanced ClusterProven, ClusterProven, and the ClusterProven design are trademarks or registered trademarks of International Business Machines Corporation in the United States and other countries and are used under license. IBM Corporation does not warrant and is not responsible for the operation of this software product. AIX is a registered trademark of IBM Corporation. Allegro, Cadence, and Concept are registered trademarks of Cadence Design Systems, Inc. Apple, Mac, Mac OS, and Panther are trademarks or registered trademarks of Apple Computer, Inc. AutoCAD and Autodesk Inventor are registered trademarks of Autodesk, Inc. Baan is a registered trademark of Baan Company. CADAM and CATIA are registered trademarks of Dassault Systemes. COACH is a trademark of CADTRAIN, Inc. DOORS is a registered trademark of Telelogic AB. FLEXlm is a trademark of Macrovision Corporation. Geomagic is a registered trademark of Raindrop Geomagic, Inc. EVERSYNC, GROOVE, GROOVEFEST, GROOVE.NET, GROOVE NETWORKS, iGROOVE, PEERWARE, and the interlocking circles logo are trademarks of Groove Networks, Inc. Helix is a trademark of Microcadam, Inc. HOOPS is a trademark of Tech Soft America, Inc. HP-UX is a registered trademark and Tru64 is a trademark of the Hewlett-Packard Company. I-DEAS, Metaphase, Parasolid, SHERPA, Solid Edge, and Unigraphics are trademarks or registered trademarks of Electronic Data Systems Corporation (EDS). InstallShield is a registered trademark and service mark of InstallShield Software Corporation in the United States and/or other countries. Intel is a registered trademark of Intel Corporation. IRIX is a registered trademark of Silicon Graphics, Inc. LINUX is a registered trademark of Linus Torvalds, MatrixOne is a trademark of MatrixOne, Inc. Mentor Graphics and Board Station are registered trademarks and 3D Design, AMPLE, and Design Manager are trademarks of Mentor Graphics Corporation. MEDUSA and STHENO are trademarks of CAD Schroer GmbH. Microsoft, Microsoft Project, Windows, the Windows logo, Windows NT, Visual Basic, and the Visual Basic logo are registered trademarks of Microsoft Corporation in the United States and/or other countries. Netscape and the Netscape N and Ship's Wheel logos are registered trademarks of Netscape Communications Corporation in the U.S. and other countries. Oracle is a registered trademark of Oracle Corporation. OrbixWeb is a registered trademark of IONA Technologies PLC. PDGS is a registered trademark of Ford Motor Company. RAND is a trademark of RAND Worldwide. Rational Rose is a registered trademark of Rational Software Corporation. RetrievalWare is a registered trademark of Convera Corporation. RosettaNet is a trademark and Partner Interface Process and PIP are registered trademarks of “RosettaNet,” a nonprofit organization. SAP and R/3 are registered trademarks of SAP AG Germany. SolidWorks is a registered trademark of SolidWorks Corporation. All SPARC trademarks are used under license and are trademarks or registered trademarks of SPARC International, Inc. in the United States and in other countries. Products bearing SPARC trademarks are based upon an architecture developed by Sun Microsystems, Inc. Sun, Sun Microsystems, the Sun logo, Solaris, UltraSPARC, Java and all Java based marks, and “The Network is the Computer” are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States and in other countries. TIBCO, TIBCO Software, TIBCO ActiveEnterprise, TIBCO Designer, TIBCO Enterprise for JMS, TIBCO Rendezvous, TIBCO Turbo XML, TIBCO BusinessWorks are the trademarks or registered trademarks of TIBCO Software Inc. in the United States and other countries. WebEx is a trademark of WebEx Communications, Inc.

    Third-Party Technology Information
    Certain PTC software products contain licensed third-party technology: Rational Rose 2000E is copyrighted software of Rational Software Corporation. RetrievalWare is copyrighted software of Convera Corporation. VisTools library is copyrighted software of Visual Kinematics, Inc. (VKI) containing confidential trade secret information belonging to VKI. HOOPS graphics system is a proprietary software product of, and is copyrighted by, Tech Soft America, Inc. G-POST is copyrighted software and a registered trademark of Intercim. VERICUT is copyrighted software and a registered trademark of CGTech. Pro/PLASTIC ADVISOR is powered by Moldflow technology. Moldflow is a registered trademark of Moldflow Corporation. The JPEG image output in the Pro/Web.Publish module is based in part on the work of the independent JPEG Group. DFORMD.DLL is copyrighted software from Compaq Computer Corporation and may not be distributed. METIS, developed by George Karypis and Vipin Kumar at the University of Minnesota, can be researched at http://www.cs.umn.edu/~karypis/metis. METIS is © 1997 Regents of the University of Minnesota. LightWork Libraries are copyrighted by LightWork Design 1990–2001. Visual Basic for Applications and Internet Explorer is copyrighted software of Microsoft Corporation. Adobe Acrobat Reader is copyrighted software of Adobe Systems. Parasolid © Electronic Data Systems (EDS). Windchill Info*Engine Server contains IBM XML Parser for Java Edition and the IBM Lotus XSL Edition. Pop-up calendar components Copyright © 1998 Netscape Communications Corporation. All Rights Reserved. TECHNOMATIX is copyrighted software and contains proprietary information of Technomatix Technologies Ltd. TIBCO ActiveEnterprise, TIBCO Designer, TIBCO Enterprise for JMS, TIBCO Rendezvous, TIBCO Turbo XML, TIBCO BusinessWorks are provided by TIBCO Software Inc. Technology "Powered by Groove" is provided by Groove Networks, Inc. Technology "Powered by WebEx" is provided by WebEx Communications, Inc. Oracle 8i run-time and Oracle 9i run-time, Copyright 2002–2003 Oracle Corporation. Oracle programs provided herein are subject to a restricted use license and can only be used in conjuction with the PTC software they are provided with.

    Apache Server, Tomcat, Xalan, and Xerces are technologies developed by, and are copyrighted software of, the Apache Software Foundation (http://www.apache.org/) – their use is subject to the terms and limitations at: http://www.apache.org/LICENSE.txt.

    Acrobat Reader is copyrighted software of Adobe Systems Inc. and is subject to the Adobe End-User License Agreement as provided by Adobe with those products.

    UnZip (© 1990-2001 Info-ZIP, All Rights Reserved) is provided “AS IS” and WITHOUT WARRANTY OF ANY KIND. For the complete Info ZIP license see ftp://ftp.info-zip.org/pub/infozip/license.html. Gecko and Mozilla components are subject to the Mozilla Public License Version 1.1 at http://www.mozilla.org/MPL/. Software distributed under the MPL is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the MPL for the specific language governing rights and limitations.

    The Java™ Telnet Applet (StatusPeer.java, TelnetIO.java, TelnetWrapper.java, timedOutException.java), Copyright © 1996, 97 Mattias L. Jugel, Marcus MeiЯner, is redistributed under the GNU General Public License. This license is from the original copyright holder and the Applet is provided WITHOUT WARRANTY OF ANY KIND. You may obtain a copy of the source code for the Applet at http://www.mud.de/se/jta (for a charge of no more than the cost of physically performing the source distribution), by sending e-mail to leo@mud.de or marcus@mud.de—you are allowed to choose either distribution method. The source code is likewise provided under the GNU General Public License.

    GTK+The GIMP Toolkit are licensed under the GNU LGPL. You may obtain a copy of the source code at http://www.gtk.org/, which is likewise provided under the GNU LGPL. zlib software Copyright © 1995-2002 Jean-loup Gailly and Mark Adler.

    OmniORB is distributed under the terms and conditions of the and GNU Library General Public License. The Java Getopt.jar, copyright 1987-1997 Free Software Foundation, Inc.; Java Port copyright 1998 by Aaron M. Renn (arenn@urbanophile.com), is redistributed under the GNU LGPL. You may obtain a copy of the source code at: http://www.urbanophile.com/arenn/hacking/download.html The source code is likewise provided under the GNU LGPL.

    This product may include software developed by the OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org/): Copyright (c) 1998-2003 The OpenSSL Project. All rights reserved. This product may include cryptographic software written by Eric Young (eay@cryptsoft.com).

    Mozilla Japanese localization components are subject to the Netscape Public License Version 1.1 (at http://www.mozilla.org/NPL/). Software distributed under NPL is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or implied (see the NPL for the specific language governing rights and limitations). The Original Code is Mozilla Communicator client code, released March 31, 1998 and the Initial Developer of the Original Code is Netscape Communications Corporation. Portions created by Netscape are Copyright (c) 1998 Netscape Communications Corporation. All Rights Reserved. Contributor(s): Kazu Yamamoto ; Ryoichi Furukawa ; Tsukasa Maruyama ; Teiji Matsuba

    UNITED STATES GOVERNMENT RESTRICTED RIGHTS LEGEND
    This document and the software described herein are Commercial Computer Documentation and Software, pursuant to FAR 12.212(a)-(b) (OCT’95) or DFARS 227.7202-1(a) and 227.7202-3(a) (JUN’95), is provided to the US Government under a limited commercial license only. For procurements predating the above clauses, use, duplication, or disclosure by the Government is subject to the restrictions set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software Clause at DFARS 252.227-7013 (OCT’88) or Commercial Computer Software-Restricted Rights at FAR 52.227-19(c)(1)-(2) (JUN’87), as applicable.

    Parametric Technology Corporation, 140 Kendrick Street, Needham, MA 02494 USA.